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Introduction

Welcome to “Get Ready for Open Source.”

My name is Geeko and I am the mascot of SUSE Linux. I will
guide you through this Linux course.

The following icons are used frequently:

❢ Read this special hint before proceeding.

i Further information is found here.

✍ Check your skills with an exercise.

This course is based on Novell SUSE Linux Enterprise Desktop
10. You will find all required software on the installation media
and the course CD.
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1 Understand the Concept of
Open Source Software

1.1 The Historical Development of UNIX

At the end of the 1960s, most operating systems were designed only for
batch operations. If you wanted to run a program, you inserted a pile of
punch cards or a roll of perforated strips into a reading device and waited
until the result was sent to a printer.

If there was an error in the program or if
you did not get the required result, you had
to rewrite the perforated roll or replace one
or several punch cards, reread the stack, and
again wait for the result.

This procedure was tedious and inefficient,
which led computer developers to look for a
way to allow a number of users to simulta-
neously use an interactive method of working
with the system.

MULTICS was one of the first programs created to meet this demand.
It allowed you to work using a dialog with the computer, but it was still
very strongly influenced by the batch operation, and it was difficult to
operate.

In 1969, one of the MULTICS developers, Ken Thompson, began creating
an operating system that, apart from an interactive operation, aimed to
provide a high functionality and structural simplicity.
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1 Understand the Concept of Open Source Software

The first version of UNIX was written in Assembler, a programming
language which approximates machine type language. To be machine-
independent in its further development, UNIX was rewritten in 1971 in
the programming language C, developed by Dennis Ritchie.

As Bell Laboratories (a subsidiary com-
pany of AT&T) provided documentation
and the source text of UNIX to universi-
ties at almost no cost, the system spread
relatively quickly.

The simple operation of the system, the almost unlimited availability of
the source code, and its relative portability motivated many users and
companies to become actively engaged in the development. Functional-
ity was added very quickly to UNIX and it reached a very high level of
maturity.

At the same time, a series of commercial UNIX derivatives arose including
versions from IBM, DEC, and HP (HP-UX, 1982), as well as BSD UNIX
(Berkeley Software Distribution, 1978), developed by the University of
California in Berkeley.

In 1983, AT&T began marketing UNIX System V commercially via its
sister company USL, proclaiming System V as “the” UNIX standard.

As a consequence of this, the licensing of UNIX changed considerably,
leading, among other things, to a long-lasting legal battle with BSD. At
the same time, with never-ending quarrels between UNIX vendors, a gen-
uine standardization of the UNIX operating system family was prevented.

Modern UNIX operating systems can still
be separated as either more System V or
more BSD like, although there are no “pure”
systems of one or the other kind. Linux tries
to combine the best of both worlds.

Linux is written in C, and is applicable to many
different hardware platforms, like Intel com-
patible processors with 32 or 64 bits, AMD and
PowerPC.

4 c©2007 Novell Inc. Copying or distributing all or part of this manual
is protected by a Creative Commons

Attribution-NonCommercial-ShareAlike 2.5 license.



1.2 The Development of Linux

✍ Exercise: The Historical Development of UNIX
Try to find the following information in the Internet:

Year when MS-DOS 1.0 was released
Year when MS-DOS 6.0 was released
Year when Windows 1.0 was released
Year when Windows 3.0 was released
Year when Windows NT was released
Year when the Apple I was developed
Year when the Apple Macintosh II was developed

1.2 The Development of Linux

In the spring of 1991, the Finnish student Linus Benedict Torvalds began
to take a closer look at the memory management of his Intel based 386
personal computer.

A few months later he had developed a rudimentary kernel which he
passed on via the Internet as source code to others who were interested.

Linus Torvalds made the source code of his Linux kernel available with
the GPL (GNU General Public License; GNU = GNU is not UNIX). The
GPL allows everyone to read and edit the source code freely. The GPL
license also requires any edited source code to be made available to the
public.

Linux rapidly developed into a project involving many people, although
the development of the system’s core functions (“Linux kernel”) is still
coordinated by Linus Torvalds. All kernel modifications are integrated by
him personally.

The functions of the kernel include input and output control, device con-
trol, process management, and file management. Other system compo-
nents (utilities, network programs, and implementations of the kernel for
non-Intel processors) are coordinated by other people or groups.
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1 Understand the Concept of Open Source Software

As a rule, there are two current versions of Linux de-
velopment: a stable one, identifiable by an even number
after the first dot, and a developer version identified by
an odd number.

Linux distributions—consisting of the Linux kernel, applications (such
as office packages, databases, and network services), and manuals—are
based on the even-numbered versions, but they often also provide current
development kernels, which, under certain circumstances, are needed for
the integration of new hardware components.

✍ Exercise: The Development of Linux
Try to find the following information in the Internet:

Who developed the GPL?
When was the first SUSE Linux released?
When did Novell buy SUSE Linux?

What other Linux distributions do you know?
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1.3 Installation of SUSE Linux Enterprise Desktop 10

1.3 Installation of SUSE Linux Enterprise
Desktop 10

1.3.1 Pre-Installation Considerations

Certain aspects of your system configuration
can be difficult to change after the initial SUSE
Linux Enterprise Desktop 10 installation. Tak-
ing time to gather certain information before
the installation begins can save you significant
re-configuration time.

Recommended system requirements:

Z 512 MB to 3 GB RAM, at least 256 MB per CPU

Z 4 GB hard disk space

Z Network interface (Ethernet or modem)

What is the expected role of the system?

Z The role of a system will determine the software packages that are
installed.

Z While it is easy to install and remove packages after installation,
experience has shown that busy administrators often neglect to re-
move unnecessary software packages after the initial installation.

Z Every software package installed on the system should be considered
a potential security vulnerability.

Z One of the most important steps in securing a system is simply
ensuring that it is not running any services that are not absolutely
required.

1.3.2 Basic Installation

Insert the installation DVD of SUSE Linux Enterprise Desktop 10 in your
DVD drive and restart your computer.
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1 Understand the Concept of Open Source Software

Select Installation by
using the cursor keys.

The program for installation and configuration is called
“YaST” (Yet another setup tool).

YaST asks you for the lan-
guage to be used during the in-
stallation process. Select your
language and select .
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1.3 Installation of SUSE Linux Enterprise Desktop 10

Accept the Novell Soft-
ware License Agreement
and select .

If you have Linux already installed on your computer, the following dialog
appears:

If there is no old installation
found on the hard drive, only New

Installation can be selected.

Select the time zone you are living in and the time zone your hardware
clock is set to.
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1 Understand the Concept of Open Source Software

YaST displays the following information on your hardware and makes
suggestions for the installation:

The Expert tab shows
all settings.

You can change these settings by selecting the headline of each of the
sections or by using the menu.
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1.3 Installation of SUSE Linux Enterprise Desktop 10

The following sections are available:
System – Lists details about your hardware.

Keyboard layout – Identifies the layout of your keyboard.

Partitioning – Lets you create and change the parti-
tioning table of your hard disk. If you
have free space on your hard disk, the
configuration program tries to use it
all for the installation.

If a Windows partition exists, YaST
tries to resize it. An existing Linux
Partition is overwritten. In any case,
you should make a backup of any par-
titions you still need.

Add-On Products – If you have foreign installation media
with add-ons, you can add them here.

Software – Lets you select the software to be in-
stalled.

Booting – Lets you install and configure the
GRUB (Grand Unified Bootloader)
boot loader.

Time zone – Lets you select your time zone.

Language – Lets you select the default language for
your installation.

Default Runlevel – Lets you select your default runlevel
for SUSE Linux Enterprise Desktop
10.

Runlevels are different modes your system can work in.
Runlevel 5 offers full networking capabilities and starts
the graphical user interface. Runlevel 3 offers only a
text interface.
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1 Understand the Concept of Open Source Software

After selecting , you
have to accept the Licenses
of Adobe and Macromedia.

The last confirmation dialog appears, before the installation starts.

Start the installation
process here.

Now the selected partition is formatted and the software is installed. This
can take some time, depending on your hardware.
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1.3 Installation of SUSE Linux Enterprise Desktop 10

If the installation of the software packages was successful, YaST stores
the information and reboots your computer.

Now you have to do some basic configuration.

1.3.3 Basic Configuration

First, specify the name of your host and the name of your domain.
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1 Understand the Concept of Open Source Software

You have to specify the
password for the root user.

For security reasons, the let-
ters of the password are
shown as stars.

The system administrator of a
Linux system is called “root.”

❢ Attention! Warnings appear if the password is too simple.

After you have specified a password, you should review your network
configuration. YaST displays a summary of the network devices it has
discovered:
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1.3 Installation of SUSE Linux Enterprise Desktop 10

The following types of network devices are displayed if the hardware is
available:

Z Network interfaces

Z DSL connections

Z ISDN adapters

Z Modems

By default, YaST selects the NetworkManager configuration for the net-
work interfaces. You can change the network configuration by selecting
the headline of the section or by using the menu.

In the next dialog, you can test your Internet connection.

If you select this option, and the test is
successful, the latest release notes will
be downloaded and YaST will check for
new updates.

If the prerequisites have been met to connect to the Internet, you should
get a success message.
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1 Understand the Concept of Open Source Software

After selecting , you can configure the Novell Customer Center, which
helps you to keep your systen up to date.

Select , to configure your
Novell Customer Center.
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1.3 Installation of SUSE Linux Enterprise Desktop 10

Import the GnuPG (GNU Pri-
vacy Guard) keys of ATI Linux
Software and NVIDIA Coopera-
tion to be informed about new
graphic drivers.

A web browser starts and you enter your email address.

After clicking through the confirmations of Novell Customer Center, YaST
looks for updates and asks if you want to start the YaST Online Update
(YOU ) module.
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1 Understand the Concept of Open Source Software

Select Run Update and
to get the latest updates.

You should apply the
available updates to en-
sure your new system
has the latest patches.

If you downloaded a patch for the Linux kernel a reboot is necessary.

Select to go to select the user authentication method.
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Select one of the following user authentication methods:

❶ Local (/etc/passwd). This setup is used for systems
where no network connection is available or where users are
not supposed to log in from a remote location at all. User
accounts are managed using the local file /etc/passwd.

❷ LDAP. (Lightweight Directory Access Protocol) User ac-
count data is managed centrally by an LDAP server. Users
must be authenticated via LDAP if you are working in a
network environment that has both UNIX and Windows
computers.

❸ NIS. (Network Information Service) User account data is
managed centrally by a NIS server. NIS can only be used
in pure UNIX environments.

❹ Windows Domain. User account data is managed by a
Microsoft Windows domain controller.

❺ eDirectory LDAP. A special LDAP implementation de-
veloped by Novell.

Select local authentication
for this course.
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If you choose Local (/etc/passwd) and select , you can start cre-
ating your first user.

Why do you have to create normal users besides the
system administrator root?
It is safer to do daily work as a normal user, because normal
users are not allowed to change important system configura-
tion files (intentional or unintentional).

To add a user, provide the following information:

User’s Full Name – The complete user’s name.

Username – The user’s login name. This name must be unique on
the system.

Password – The case-sensitive login password for the user. You
have to enter the password twice for verification.
YaST displays warnings if the password chosen is con-
sidered vulnerable or insecure.

For security reasons, the letters of
the password are shown as dots.

If you want the user to receive automatically generated email for root,
then select Receive System Mail.
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If you use your Linux computer only at your own desk and you want to
avoid the login during the startup, select Auto Login option.

❢ Attention! For security reasons, we recommend that you
deactivate the auto login option, since anyone who turns on
your machine has full access to all the files stored there.

After setting up one or more users, the system information is written to
disk. YaST opens a window with the release notes.

Go to the last step of the
installation by selecting

.

At this point, the final configuration dialog appears (hardware configura-
tion):

From this dialog you configure additional hardware items such as the
following:
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Z Graphic card

Z Printer

Z Sound card

YaST configures the graphic card and the
sound card automatically. YaST also detects
some printers automatically.

Confirm the settings and write them to the system by selecting .

The last dialog tells you that the installation was successful. Select .
SUSE Linux Enterprise Desktop 10 is now ready for use.
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✍ Exercise: Installation of SUSE Linux Enterprise
Desktop 10
Install the SUSE Linux Enterprise Desktop 10 on your system.

The following table will lead you through the installation pro-
cess and information on the data you have to enter.

Language English
Installation Settings Accept defaults
Root Password novell

Network Configuration Accept defaults (NetworkManager)
Test Internet Connection Yes
Run Online Update Yes
Service Configuration Accept defaults
User Authentication Method Local authentication
Local Users Name: Geeko Chameleon

Login: geeko
Password: novell

Hardware Configuration Accept defaults
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2 Understand the GUI
Environment

2.1 Introduction

With Microsoft Windows, it is impossible to install a computer without its
graphical user interface (GUI). In Linux, the GUI is a normal application
that you can choose whether or not to install, since most functions can
also be completed in a text based interface.

Most services in Linux can be configured by editing an ASCII text file,
so you do not always need a GUI if you want your computer to act only
as a server.

Not installing a graphical user interface has the following
advantages:

❶ Stability. Every program contains errors that can make
your system unstable. The fewer programs that are in-
stalled, the more stable your system will be. A graphical
user front end is a large program that might contain a large
number of undiscovered programming errors, even if the er-
ror ratio is low.

❷ Performance. Every running program needs system re-
sources. Fewer programs running on your computer means
increased performance.
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2.2 Overview of the Linux Desktop

The basis of any graphical user interface is the X Window System (simply
called X or X11). It allows you to control the input and output of several
applications in different windows of a graphical interface.

It is important to distinguish between graphical applications, which run
in their own windows, and text-based applications, which are carried out
in a terminal window.

The X Window System was created in 1984 at MIT
(Massachusetts Institute of Technology). The aim
of the development was to be able to use graphi-
cal applications across a network, independent of
hardware.

The X Window System allows graphical applications to be displayed and
operated on any monitor, without running the applications on the ma-
chines to which these monitors are connected.

The basis for this is the separation into a server component (X server)
and the application itself (client application). The X server and client ap-
plication communicate with each other by way of various communication
channels.

Z X server. The X server controls the graphical screen. This corre-
sponds roughly to what would be called a graphics driver on other
systems. In addition, it manages the input devices, such as keyboard
and mouse, and transmits their actions to the X client.

The X server, however, has nothing to do with the appearance of the
window and the desktop; this is the task of the window manager.
XFree86 3.3.x and its successor XFree86 4.x are free implementa-
tions of the X server. SUSE Linux Enterprise Desktop defaults to
using X.Org.

Z Client application. The client application is a graphical applica-
tion that uses the services of the X server to receive keyboard and
mouse actions, and to have its own output displayed on the screen.
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The communication between X server
and X client uses the network proto-
col TCP/IP—even if the server and
client run on the same computer.

As shown in the following figure, the X server is running on computer
da5, while the X applications are running on computers da1 and da2:

Network

da1

da2

da5
X Server

X Application
da2

X Application
da1

The display of the client applications, however, is performed by the X
server on the machine da5. All of these computers can be running different
operating systems (at the same time).

Window managers are specialized client applications. A window manager
works together with the X server and provides additional functions. The
window manager:

Z Provides control elements

Z Manages virtual desktops

Z Provides functions of window frames (for example, changing their
size)

The X Window System is not linked to any specific window manager and
thus it is not linked to any particular look and feel.
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The distinction between the X server, client application, and window
manager is not noticed during normal operation; once you have logged in
by way of the graphical login, the entire environment is available.

SUSE Linux Enterprise Desktop 10 is currently released with several
window managers, including Metacity (the GNOME window manager;
GNOME = GNU Network Object Model Environment) and twm (Tab
Window Manager).

Desktop environments go far beyond the look and feel which window
managers provide for desktops and manipulating windows. The aim is
to provide clients with a unified look and feel. GNOME is the standard
graphical desktop for SUSE Linux Enterprise Desktop, but you can install
the KDE interface instead, if you choose.

✍ Exercise: Overview of the Linux Desktop
To identify the structure more clearly, the components can be
started individually.

Enter 3 at the boot option screen
when you start your system.

The system will start without any graphical environment.
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Enter root as login and novell as password.

You are logged in successfully as root when you see a prompt
like

1 da51 :~ #

Enter X & to start the X server.

The result of this command is a gray area with a mouse pointer
cross. Users cannot use the pure X server in a meaningful
way, but X applications can use the X server for the graphical
output.

Press Ctrl + Alt + F1 to switch back to the console from
which the X server was started.

If you start a graphical application from this console, the fol-
lowing error message is displayed:

1 da51 :~ # xterm

2 ...

xterm Xt error: Can ’t open display : %s

4 xterm: DISPLAY is not set

The application “xterm” lacks the information on the X server
to be used. The X server needs to be addressed specifically,
as it may be active on the same machine or on a different
machine, or several X servers may be active on one machine.

Graphical applications interpret the variable
DISPLAY, which contains the necessary
information. However, in the above example,
this variable is not set.

Enter DISPLAY=:0 xterm & and you won’t get any errors.

You can switch back to the X server by pressing Ctrl + Alt +
F7. Here you can see the xterm window in the top left corner.
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If you move the mouse pointer over the window, commands
can be entered within the window, but you cannot move the
window by using the mouse.

Enter twm & to start the simple window manager twm.

Now you can move the window by clicking the title bar and
holding down the left mouse button.

To restart the X server and unload the running X clients, press
Ctrl + Alt + Backspace.

To set your computer back into the default state, enter init
5; exit.
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2.3 Use the GNOME Desktop Environment

2.3.1 How to Log In

If computer users want to work with a multiuser-capable operating sys-
tem, they must first identify themselves to the operating system. For this
purpose, they need

Z A login string or username

Z A password (usually assigned by the system administrator when a
new user is added)

When the computer is booted and ready for work, the following login
dialog appears:

Enter your username here and press
Enter to enter your password.

After entering a username and password, press Enter .

If the login is successful, the GNOME desktop environment appears.
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2.3.2 How to Identify GNOME Desktop Components

The GNOME desktop includes a panel at the bottom of the screen:

The panel at the top of the desktop is responsible for launching applica-
tions. The following features are available (from left to the right):

Main menu for launching applications
Write post-it notes on your desktop

A task manager

Applet for NetworkManager

Displays information and settings
Informs you when new updates are available
Volume control
A clock

The board minimizes all open windows or
shows them again on the desktop

✍Exercise: Identify GNOME Desktop Components
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Label the items of the GNOME desktop on the following
screenshot.
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You can start a program with an icon on the desktop by double-clicking
the icon. But normally programs are started from the main menu.

In the Search textbox you can enter
the name of a file or application.

At the top of the left frame there is a pull-down menu labeled Show show-
ing three different filters:

Z Favorite Applications

Z Recently Used Applications

Z Recent Documents

In the left frame, there is also a button . If you select this
button, the application browser appears.
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Enter a part of the name of the
application you want to start here.
The filtered applications are shown
immediately in the right frame.

The right frame of the application browser shows a list of the most im-
portant installed applications. The applications are grouped and you can
see a list of the groups in the left frame. Select a group to see only the
applications that belong to this group.

In the right frame of the main menu, there are five system options:

– Starts the online help.

– Starts the GNOME Control Center where you can config-
ure your desktop.

– Shows a list with the available software on your registered
installation media.

– Locks the screen. To unlock you have to enter your pass-
word.

– Must be selected to log out of the system.

At the bottom of the right frame you can see the status of your hard
drives and network.

To start an application select the icon in the main menu or the application
browser with a single mouse click.
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2.3.3 How to Log Out

When you are ready to log out of the system, open the main menu
in the bottom panel. At the right side of the Computer menu, select

. A confirmation dialog appears.

If you select Save current setup, your cur-
rent desktop environment settings are saved
and restored after your next login.

Select after selecting an action.

2.3.4 How to Manage Icons in GNOME

There are icons in the following three areas on your desktop:

Z Desktop

Z Panel

Z Application Menu

Desktop

You can create a new icon on your desktop in different ways. For the sake
of simplicity, we will describe only one method.
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To create an icon for an application on your desktop, select the item in
your Applications menu or file manager and drag it to a free space on
your desktop. If you release the mouse button, the new icon will appear
on the desktop.

Notice there is a small plus icon at the mouse
pointer when moving the icon. This indicates
that a copy of the icon will be created.

To create a new icon right-click a free space on your desktop. A menu
pops up.

At the top of the pop-up menu there are three entries to create a new
item:

Create Folder. Creates a new and empty folder icon. When the icon
appears you can enter the folder’s name.

Create Launcher. Creates a new application launcher. A dialog appears:
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Enter the following information:

Z Name. Name of the launcher.

Z Generic name. (Optional) Enter the class of application to
which the launcher belongs (e. g., Text Editor).

Z Comment. (Optional) This comment is shown as a tool tip
when moving the mouse pointer over the icon.

Z Command. Command that should be executed when double-
clicking the launcher icon.

Z Type. You can create launchers for different file types (e.g.,
application, directory, link, device) using this dialog.

Z Icon. (Optional) Select an icon for the launcher.

Z Run in terminal. Select this option if the application does
not have a graphical user interface and runs in a terminal win-
dow.

Create Document. You can create an empty document by using this
menu.

Depending on your installed software there are
various document types available in this menu.
After a default installation there is only the
possibility to create an empty text file.

When the icon appears you can enter the text file’s name.
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Panel

You can add new programs to the bottom panel by right-clicking a free
area of the panel and then selecting Add to Panel. From the dialog that
appears, select the application you want to add.

If you want to add an application laucher, select
Custom Application Launcher or Application

Launcher from the top of the list.

You can remove a program from the control panel by right-clicking its
icon in the bottom panel and then selecting Remove From Panel.

You can move icons in the panel by holding down the right mouse button
and selecting Move from the context menu.

Main Menu

To add an entry to a menu, do the following:

❶ Open the main menu in the panel. The menu appears.

❷ Select .
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❸ Select an application item in the right frame with the right mouse
button.

❹ Select Add to Favorites from the pop-up menu.

Your favorites are shown when you se-
lect filter Favorite Applications.

✍ Exercise: Manage Icons in the GNOME Environ-
ment
There is a calculator program called “Gnome Calculator”.
Create an icon to start the Gnome Calculator program

Z at your desktop

Z in the bottom panel

Z in the main menu

2.3.5 Use the GNOME File Manager (Nautilus)

GNOME provides its own file manager (called Nautilus).
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Although Nautilus does not provide as many features
as other file managers, it contains the features you need
for most file navigation tasks. You can start Nautilus
by selecting the username Home icon on the desktop.

Normally, Nautilus shows the content of the user’s home directory after
starting.

The left frame of the Nautilus windows shows the content of the current
directory.

You can see your current position in the location bar below the tool bar.
All higher directories are shown as buttons. Select one of these buttons
to switch into the higher directory.

GNOME and its applications try to simplify
the work by providing only selected features.
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The items on the toolbar are

– Go back to the last position

– Go forward (after back)

– Go up one level

– Stop loading

– Reload

– Go to the home directory

– Shows all available file systems

– Search for files

The right frame is called Side Panel.

To change the content of the
side panel, use this menu.

The following side panel tools can be chosen:

Z Places. Shows the most important directories and devices to store
files.

Z Information. Shows some information about the current directory.

Z Tree. Shows the file system tree and the tree of the home directory.

c©2007 Novell Inc. Copying or distributing all or part of this manual
is protected by a Creative Commons

Attribution-NonCommercial-ShareAlike 2.5 license.

41



2 Understand the GUI Environment

Z History. Shows a history of the last visited directories.

Z Notes. Enter notes for the current directory.

Z Emblems. Shows the list of emblems.

To add an emblem to an icon use drag and drop.

Use Erase to remove all emblems from the icon.

Manage the File System with Nautilus

Before we describe how to manage the file system, you have to know some
basics about the Linux file system.

File Names in Linux A file name can be up to 255 characters long. It
may contain any number of special characters (“ ” or “%”, for example).
Certain special characters (the dollar sign “$”, the semicolon “;”, or the
space, for example) have a specific meaning. If you want to use one of
these characters without the associated special meaning, the character
must be preceded by a “\” (backslash) so its special meaning is masked
(switched off).
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Umlauts, letters with diacritical marks, or other country-specific char-
acters can be used. Using them, however, can lead to problems when
exchanging data with people in other countries using other settings if
these characters are not present on their keyboards.

Linux differentiates between uppercase and lowercase letters.
For example, Invoice, invoice, and INVOICE identify three
different files.

Basic Principles The Linux file system is a hierarchical arrangement
of directories and files. The basic structure is the same for all UNIX
derivatives. Data is classified according to the following criteria:

Z Static files (those that are not modified during operation, such as
documentation) are distinct from dynamic files (those that can be
changed, such as configuration files).

Z Files are ordered according to their functions, such as executable
programs, configuration files, or help files.

Z Operating system files are distinct from user files.

Structure The hierarchically built file system starts with the root di-
rectory (root), which is denoted by the slash, “/”. The root directory
contains a series of directories and subdirectories ordered and organized
according to the above-mentioned principles.

c©2007 Novell Inc. Copying or distributing all or part of this manual
is protected by a Creative Commons

Attribution-NonCommercial-ShareAlike 2.5 license.

43



2 Understand the GUI Environment

When referring to such a subdirectory, the slash (with-
out a space) is placed in front of the directory (/home/,
for example). Further subdirectories are also separated
from each other by a slash (/home/geeko/).

A characteristic of the Linux file system is that the structure does not de-
pend on the physical storage medium in which the directories are actually
located.

For example, if a computer is equipped with two hard
drives, the /usr/ directory can be stored on one drive
and all user data (the /home/ directory) can be stored on
the other drive. Both directories are, however, directly
attached to the file system in the root directory, so users
do not even notice that the hard drive has changed when
they change directories.
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The Most Important Directories – Home directories
Z The /home/ Directory. As many people can work on a

Linux system at the same time, the data of an individ-
ual user must be clearly separated from that of another
user. To achieve this, each user is assigned a home area
(/home/name/). This directory can be organized accord-
ing to personal requirements. This is where directories can
be created, data stored, and personal programs installed.

The path for the user’s home directory can be ab-
breviated with the tilde (“∼”). For example, for
the user geeko, ∼/Documents/ corresponds to the path
/home/geeko/Documents/.

Z The /root/ Directory. The system administrator (called
root in Linux) also needs a home directory. This directory
is called /root/.

The Most Important Directories – Other storage
Z The /media/ Directory. /media/ contains a subdirec-

tory for each replaceable medium (for example, floppy disk
drives, CD-ROM drive, CD burner, USB stick). Here, the
contents of such a data storage medium are mounted into
the file system.

Z The /mnt/ Directory. /mnt/ is the default directory for
temporarily mounting file systems such as other partitions
or for accessing directories exported over the network.

Z /dataX/ Directories. Depending on the hardware equip-
ment and the configuration of the computer, the root di-
rectory may contain directories like /data1/, /data2/,
/data3/, and so on. These directories allow access to other
hard disks or partitions.
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The Most Important Directories – Temporary files
Z The /tmp/ Directory. In the /tmp/ directory, some

programs create temporary files to store data. The
content of this directory is regularly deleted, depending
on the configuration, sometimes upon system start-up.

Create Directories To create a new file directory, click the white back-
ground of Nautilus with the right mouse button. A popup menu appears:

Select Create Folder to
create a new directory.

Alternatively, you can select Create Folder

from the File menu of Nautilus.

A new folder icon appears and you can enter the
directory’s name.
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✍ Exercise: Create Directories
Create a directory called GNOMEFiles in your home directory.

Copy and Move Files

The explanation for using files below is also
valid for directories.

One way to copy or move a file is to drag and drop the file icon
from one Nautilus window into another.
If you hold Ctrl while you are moving the mouse pointer, the
file is copied.

You can also use the popup menu. Right-click the icon of the file you
want to copy and select Copy. If you want to move the file, select Cut.

To copy and move several files at the same time,
hold down Ctrl while you are selecting files.

The items Cut and Copy.
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Now you can navigate to the directory you want to copy the file to. Right-
click the white window background and select Paste Files from the
popup menu.

You also can use
shortcuts:

Z Copy.
Ctrl + C

Z Cut.
Ctrl + X

Z Paste.
Ctrl + V

✍ Exercise: Copy and Move Files
Copy the file /usr/share/cups/calibrate.ppm to the direc-
tory ∼/GNOMEFiles/.

Rename Files To rename a file, right-click it, select the entry Rename

from the popup menu and enter the new file name.
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You can also use the entry Properties for renaming files. At the Basic

tab, enter the new name.

Enter the new
file name here.

✍ Exercise: Rename Files
Rename the file calibrate.ppm in the ∼/GNOMEFiles/ direc-
tory to first picture.ppm.

Delete Files You can prepare to delete files by moving them into the
trash.

Files thrown into the trash can be
restored before the trash is emptied.
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To throw a file in the trash, select Move to Trash from the popup menu.

❢ Attention! Nautilus does not ask for confirmation when mov-
ing a file to trash.

You can also move a file to the trash by dragging the file with the mouse
over the trash icon and then releasing the mouse button.

The trash icon on the desktop
changes as soon as it contains
something.

To view the contents of the trash, double-click it. You can see the files
that have been moved there and you can even retrieve then.

A file that has been thrown in the trash has not really been deleted, so
it still takes up hard drive space. To permanently remove or delete the
items in the trash, empty the trash.
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To empty the trash, right-click the trash
icon on the desktop. In the popup menu,
select Empty Trash.

Connect Files Using Links

Links are references to files or directories. Us-
ing links, you can access a file multiple times
from different locations in the file structure,
without the file physically existing in each loca-
tion. Links are useful to keep order and avoid
redundancy.

If you are working with a linked document, the original file is stored in
only one directory, but a link to the document may be stored in other
directories. The original file can be opened in two ways: by opening the
original file or by opening the link. The link is only a pointer to an original
file, which is located somewhere else in the file system.

A link can be identified by
the small arrow on the icon.
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To create a link, select Make Link from the popup menu that appears
when you rightclick an icon.

You can also create a link by using drag and drop. Therefore, you have
to keep Alt pressed while moving the mouse. If you release the left
mouse button after moving the mouse pointer, a popup menu appears.
To create a link, you have to select Link here.

Copying, moving, renaming, and deleting links works in the same way for
both files and directories.

✍ Exercise: Connect Files Using Links

❶ Create a link to the file ∼/GNOMEFiles/

first picture.ppm in your home directory.

❷ Rename the link’s name to first link.

❸ Move ∼/GNOMEFiles/first picture.ppm to trash.

❹ Test what happens when you select the link.

❺ Empty trash.

Use the Linux File Permissions To separate the data of different users
on a Linux multiuser system, users are assigned their own home directories
in which to store personal data. This separation of data does not protect
data effectively against unauthorized access by other users. Owner and
access permissions are assigned to stored data and executable programs.
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To facilitate data access, users are divided into three categories:

❶ Each directory and each file is first uniquely assigned an owner.

❷ In addition, each user belongs to one or more groups of users, who
might work together on a project and need access to the same data,
for example. For this reason, files are assigned not only to an owner,
but also to a group.

❸ All other users apart from this group are referred to as others.

There are three possible permissions:

❶ Read (short form: r)

❷ Write (short form: w)

❸ Execute (short form: x)

Although they are similarly labeled in the permission dialog, the permis-
sions for files and the permissions for directories are different. For files,
the permissions mean:

Read – authorized to see the file’s content – read access

Write – authorized to change the file’s content – write access

Execute – authorized to run the file as a program – execute access

For directories, the permissions mean:

Read – authorized to list the contents of the directory access

Write – authorized to create or delete files or access

Execute – authorized to enter the directory

For each file, you have to configure these three permissions for the file
owner, the associated group, and others.

To view and change the permission, right-click an icon, select Properties
and activate the Permissions tab.
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Change the file’s
group here.

There are also some “special” permissions available.

Name Meaning for files Meaning for directo-
ries

Set user ID The program is running
with the owner’s permis-
sions.

./.

Set group ID The program is running
with the permissions of
the group assigned.

The files in the direc-
tory belong to the direc-
tory’s group and not to
the user’s group.

Sticky ./. The user can only delete
files if they belong to him
or if he has explicit write
permission.

❢ Attention! These permissions should be used very carefully.
They are only explained here briefly.
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✍ Exercise: Use the Linux File Permissions
Change the permissions of the directory ∼/GNOMEFiles/ that
only you have the permission to view and change the content.

2.3.6 How to Search for Files

Sometimes you have to find a file, but you do not know exactly where it
is in the file system. You might know the name of this file or only a part
of the file content.

“Beagle” is a desktop search engine similar to search engines on the inter-
net. Beagle searches your files not only by name or date, it also creates a
search index based on the file content and metadata.

It can index all kinds of files and information on your computer (txt, pdf,
doc, emails, images, music, etc.).

Enter the search
string here.

One of the exiting features of Beagle is the live query functionality. The
search results are updated in real time. For example, if you receive an
email with the search term included, the email will be instantly shown in
the desktop search window.
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To find files with specific features, select the GNOME Search Tool from
the System group in the Application Browser.

Enter the search
string here.

If you do not know the whole name of the file, you can use the wildcards
“?” (for any character) and “*” (for none, one, or several characters) in
the GNOME Search Tool.

56 c©2007 Novell Inc. Copying or distributing all or part of this manual
is protected by a Creative Commons

Attribution-NonCommercial-ShareAlike 2.5 license.



2.3 Use the GNOME Desktop Environment

Example: Suppose the following files exist:

Z File

Z file

Z File1

Z File1a

Z File1b

Z File2

Z File2a

Z FILE

Z MyFile

The following table shows the results of three different search
strings:

Search string File? File* ?ile*

Found Files File1 File File

File2 File1 file

File1a File1

File1b File1a

File2 File1b

File2a File2

File2a

Enter the directory you want to search in Name contains. You can also
use the menu Look in folder to specify the directory you want to search
in.

Select to start the search process. All matching files and directo-
ries are shown in the lower window with details of their locations.

Further settings can be made when you open the menu under Show more

options.
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Select a search rule from the pull-
down menu Available options.

After selecting the , a new text field is added and you can enter
the information necessary for the chosen option. To remove a search rule,
select the next to the rule.

✍ Exercise: How to Search for Files
Use Beagle to search for “novell”. Let the search dialog open
and create a new OpenOffice document with the following
content:
It starts with Novell.

Save the file under the name “testdoc” in your Documents
directory.

In your home directory, search for files that are older than one
day.

2.3.7 How to Archive Files

With the program File Roller, you can pack multiple files or even entire
directories into an archive. This can be very useful to

Z Back up data

Z Prepare data to be sent via floppy disk or email by compressing it
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To back up files by using File Roller is very
useful, because the file structure of a directory
will be recreated when you unpack the archive
later.

You can start File Roller from the main menu. The
launcher is in the Tools section of the Application
Browser.

The following appears:

Before you start to archive files, create a new archive. Select the New

button in the toolbar to open a window to specify the archive’s path and
name.

When you select , an
empty archive is created here.
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In Linux, the standard file format for archives is .tar
(from tape archiver ; originally this was developed for
data backup on magnetic tape).
Sometimes, tar files become quite large, but you can
compress them. File Roller carries out archiving and
compressing in one step if you use .tar.gz as the file
format.

File Roller also handles the .zip format used in Microsoft Windows envi-
ronments.

File Roller supports the following file formats:

Z Ar archives (*.ar)

Z Ear archives (*.ear)

Z Jar archives (*.Jar)

Z Tar uncompressed (*.tar)

Z Tar compressed with bzip2 (*.tar.bz2)

Z Tar compressed with gzip (*.tar.gz)

Z War (*.war)

Z Zip archives (*.zip)

If you select the Automatic archive type, you have to enter the suffix
(e. g., *.zip) after the file name.

To fill the archive, drag the files you want to archive from Konqueror onto
the empty window.

To open an existing archive (whether it is compressed or not), select the
file in Nautilus or start File Roller and then select Open. The contents of
the archive are displayed.

Using the mouse, you can drag individual files from the archive window
and place them in a Nautilus window. You can also unpack the entire
archive by selecting Extract.
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✍ Exercise: Archive Files
Create archives and include the content of the /bin directory.
Use the following file formats for these archives:

Z .zip

Z .tar

Z .tar.bz2

Compare the file size of the different archive types.

2.3.8 How to Customize GNOME

GNOME provides a lot of configuration modules that are accessible via
the main menu.

Select Control Center.

The Contol Center contains four categories with a different number of
modules. Some of the listed modules are for system-wide configurations.
Only root is allowed to do this. You have to authenticate first.

Hardware Category

Here, you can configure accessibility features for handicaped people.
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Bluetooth Configure Bluetooth. Only root is allowed to do this.

DSL Configure a DSL connection. Only root is allowed to do this.

Graphics Card and Monitor Configure your graphics card and monitor.
Only root is allowed to do this.

Keyboard Keeping a key on your keyboard pressed, after a short delay,
the output of the keyboard begins to repeat.

In this module, you can specify the delay and the speed of repeat.

The cursor blink frequency can also be configured.

Here, you can test your
keyboard settings.

In the Layouts tab you can specify your keyboard model and layout. In
the tab Layout Options you can configure the behavior of special keys,
e. g. Win key. If you want to enforce typing breaks, configure them at the
Typing Break tab.
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Modem Configure a modem connection. Only root is allowed to do this.

Mouse In the Buttons tab, you can swap the mouse buttons if you are
left-handed. You can also change the speed for double-clicks.

Here, you can test the
double-click speed.

In the Cursors tab there are three sizes for the mouse pointer available.
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If this checkbox is activated,
the mouse pointer is highlighted
when you are pressing Ctrl .

In the Motion tab change the mouse speed and sensitivity.

Network Card Configure network card and connection. Only root is
allowed to do this.

Printers Manage your printers and view the print queues.

Double-click a printer
icon to see the queue.
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Removable Drives and Media When you insert an audio CD into your
CD drive, the player Banshee starts automatically. This automatism you
can configure here for the following devices and medias:

Z Removable storage

Z Blank CDs and DVDs

Z Audio CDs

Z Video DVDs

Z Portable music play-
ers

Z Cameras

Z PDAs

Z Printers

Z Scanners

Z Mices

Z Keyboards

Z Tablets

Scanner Configure a scanner. Only root is allowed to do this.

Screen Resolution Here, you can switch to another screen resolution or
select a different refresh rate.

c©2007 Novell Inc. Copying or distributing all or part of this manual
is protected by a Creative Commons

Attribution-NonCommercial-ShareAlike 2.5 license.

65



2 Understand the GUI Environment

Look and Feel Category

Desktop Background In this module, you can specify your desktop
background.

Select a background picture in the upper frame..

In this menu, you can specify the
alignment of the selected picture.

Instead of a picture, you can select a solid color background or a gradient
background.

Desktop Effects If you activated 3D acceleration for your graphic card,
you can enable various desktop effects here. Only root is allowed to do
this.
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Fonts In this module, you can select fonts for your desktop and the kind
of font rendering you prefer.

Select the render type
that looks best.

Select one of the four font buttons to change the font or its size.

A new dialog appears.
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Menus & Toolbars This module offers some features concerning the
appearance of menus and window toolbars.

Screensaver Select a screensaver and an idle time to start the screen-
saver.

If this option is activated, you
have to enter your password to
unlock the screen.
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Theme A GNOME theme consists of a set of colors, window borders
and icons. You can select a complete theme from the list. If you change
a theme, use the item Custom theme. To save these settings, select

.

Select this button to change
the theme settings.

After selecting , a dialog appears
to change the GNOME appearance.

To install a new theme, select .

❢ Attention! After installing or creating a new theme, restart
the theme module.

i At http://themes.freshmeat.net/, you find a lot of themes.
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Windows In this module, you can configure three things:

❶ In Microsoft Windows and Macintosh OS, windows can be focused
by a mouse click. In some GUIs of UNIX, a window gets the focus
when the mouse pointer moves onto it.

❷ The action when a window titlebar is double-clicked.

❸ Move a window by pressing the specified key and selecting it with
the mouse.

Personal Category

Accessibility Enable keyboard accessibility features, e. g., repeat keys,
bounce keys.

Assistive Technology Enable assistive technologies for handicaped peo-
ple, e. g., screen reader.

Password Change your user password.
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Novell CASA Mananger Common Authentication Service Adapter
(CASA) is used to manage your user credentials. You can configure it
here. Only root is allowed to enable CASA.

Shortcuts Here, you can configure keyboard shortcuts for system ac-
tions.

Select a line and enter your key combination. To disable the shortcut,
type backspace.
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System Category

Date and Time Control time zone, date and time. Only root is allowed
to do this.

GStreamer Properties Select a software plugin for audio and video in-
put and output.

If you want to access the sound output of other computers in your network,
or allow others to access to your sound system, you can activate that here.

Language Select the language of your system. Only root is allowed to
do this.

Network Proxies Configuration for accessing the Internet via Proxy.

Power Management To save energy
(e. g. when using a laptop computer)
you can specify the idle time, when the
computer is put into sleep mode.
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Preferred Applications Select your preferred web browser, mail client,
text editor, and terminal emulation.

Remote Desktop Here you can allow others to view your desktop over
the network. You also can allow them to control mouse and keyboard.
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Search Settings Beagle uses an automatically created index to find files
very fast. In the Search Settingsmodule you can allow that the index is
updated automatically in the background. You also can specify directories
that should (not) be indexed.

Sessions You can save the state of the running applications. When you
log in the next time, all windows will be restored.

When you log out of
GNOME, you can save
your session.

With the Sessions module, you can manage your saved sessions.

74 c©2007 Novell Inc. Copying or distributing all or part of this manual
is protected by a Creative Commons

Attribution-NonCommercial-ShareAlike 2.5 license.



2.3 Use the GNOME Desktop Environment

At the tab Current Session,
you can view the running appli-
cations. At Startup Programs,
you can select programs that
should be started automatically
after your login.

Sound In the Sounds tab , you can configure sounds for some system
events. For example, the sound that is played when a warning message
appears.

In the System Bell tab, you can deactivate the audio bell of the internal
PC speaker. You can enable visual feedback instead if necessary.
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User Management Manage the user accounts. Only root is allowed to
do this.

YaST Start the system configuration tool YaST. Only root is allowed
to do this.

✍ Exercise: How to Customize GNOME
Search the Internet for a GNOME theme and install it.
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2.4 Use the KDE Desktop Environment

2.4.1 Install the KDE Desktop Environment

GNOME is the default desktop environment of SUSE Linux Enterprise
Desktop 10. If you want to use the KDE desktop environment instead,
you have to install the KDE software packages first.

Normally, you will install KDE during the in-
stallation of SUSE Linux Enterprise Desktop
10, but you also can install it later and next to
GNOME.

You can install new software using the configuration tool YaST.

YaST can be found in the System

group in the Application Browser.

Only the root user is allowed to start YaST. To prevent illegal access, you
have to authenticate by entering the root password.

The YaST dialog is divided into two frames. In the left frame you can see
seven categories. In the right frame the modules of the selected category
are shown.
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Select a category to
see the modules.

In the Software category, there is a module
labeled Software Management.

Select the icon Software Management once with the mouse. After a few
seconds, the software module appears.

SUSE Linux Enterprise Desktop contains a broad range of software. When
selecting individual packages, you can use different filters to display the
available software packages.

Select a filter.
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The following filters are available:
Z Patterns. Displays all software that is available

on the known installation media. It is grouped in
predefined sets of packages that logically belong
together.

Z Package Groups. Displays all software packages
that are available on the known installation media.
It is grouped by category.

Z Languages. Displays all language related files
(e. g., spell checker, help)

Z Installation Sources. Lists all registrated in-
stallation sources and displays the available pack-
ages of this source.

Z Search. Lets you enter a search term and select
where you want YaST to search.

Z Installation Summary. Displays all the pack-
ages with the marked status.

In most cases you will use Search to find the items you want to install.
Enter the full package name, part of the name, or keywords in the Search
text field and select . The results are listed in the right window.
The install state is shown by a small symbol in front of the package name.
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The most important symbols are shown in the following (get a complete
list by selecting Help → Symbols):

Select the symbol of the package you want to install until the symbol
appears; then select .

You might see a dialog indicating that the depen-
dencies between the packages cannot be resolved
and that some other packages need to be installed
as well. In most cases, you can confirm this dialog.

If the wrong DVD or CD is in your
drive, a warning appears.
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✍ Exercise: Install the KDE Desktop Environment
As the KDE desktop environment consists of a lot of software
packages, use the Pattern filter to install all KDE packages.

Select the KDE pattern.

2.4.2 How to Log In

If you want to log into the KDE desktop environment the first time, you
have to select Session at the login screen.

Select Session.
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The following login dialog appears:

Select KDE to start the KDE
desktop environment.

You are asked whether you
want to make KDE your de-
fault desktop environment.

When you enter your login data, the KDE desktop environment appears.
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2.4.3 How to Log Out

When you are ready to log out of the system, open the KDE menu by
selecting the first (left) icon on the bottom panel:

This menu is called
“KDE menu”.

At the bottom of the KDE menu, select the Log Out entry. You can also
right-click on the window background and select the same option from
the popup menu.

After selecting Log Out, a confirmation dialog appears.
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If you select this button, you are
logged out and the login screen re-
appears, allowing you or another
person to log in.

2.4.4 How to Identify KDE Desktop Components

After you log in, your system will start the KDE desktop environment by
default. It is composed of

Z The Desktop

Z The KDE Control Panel (Kicker)

Z The KDE Menu

Z Virtual Desktops

The Desktop

On the desktop you will see only a few icons. You can start the applica-
tions associated with these icons by clicking them once with a left mouse
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click.

You can move the
icons by dragging
them with the mouse.

The KDE Control Panel (Kicker)

The KDE desktop is operated by using the mouse on the KDE control
panel (called Kicker) located at the bottom of the desktop:

The following are the most commonly used icons and their functions (from
left to right):

Menu of all configured programs and functions (not of
all programs and functions installed on the machine).
This menu is called the KDE menu.
Konqueror, the preferred KDE file manager

A terminal window in which to type commands directly

The SUSE Help Center
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Konqueror, as preferred KDE Web browser

The personal information manager Kontact (including
email, address book etc.)
Virtual desktops

A sound mixer
A tool to control the power management

Software Updater for automatic updates
Clipboard
Beagle search

Applet for NetworkManager
Current time and date

The KDE Menu

Programs are normally started from the KDE menu. You can select the
KDE menu button to open the KDE menu.

In the bottom part of the menu a command line interface, an overview
of the recent documents, shortcuts for important positions in the filesys-
tem, an option for locking the screen, and the option for logging out are
provided.

The upper section of the menu features an overview of various applications
sorted by subjects (such as Office).

There is a text field for filtering at the top of the menu. When the menu
is open, enter “/” and the application you are looking for.
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The path to applications
that match the entered
name are highlighted.

A submenu in the KDE menu is marked by a small black arrow in the
right-hand corner. To open a submenu, move the cursor over the menu
entry. To start a program, click the corresponding entry once with a left
mouse click.

Submenus are marked
by a small black arrow.
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Virtual Desktops

If you are working with several programs simultaneously, the screen can
quickly become cluttered with open windows. In Linux, you can bring
order to this chaos by changing to another (virtual) desktop. You can
switch between the various desktops via the control panel.

By default, two virtual
desktops are configured.

In the KDE control center, you can increase the number of usable virtual
desktops up to sixteen. Every virtual desktop can host a virtually unlim-
ited number of applications. Using these virtual desktops, you can easily
organize your work.

In GNOME there is an applet “Workspace
Switcher” you can add to your panel. In the
preferences of this applet you can specify the
number of virtual desktops.
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✍ Exercise: Identify KDE Desktop Components
Label the items in the following screenshot.
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2.4.5 How to Manage Icons in the KDE Environment

You can find icons in your KDE environment in three areas:

Z Desktop

Z Kicker

Z KDE Menu

Manage Icons on the Desktop

You can create a new icon on your desktop in different ways. For simplic-
ity, we will describe only one method.

❶ To create an icon for an application on your desktop, select the item
in your KDE menu.

❷

Hold down the left mouse but-
ton, move the mouse pointer to
free space on your desktop, and
release the mouse button.

❸

In the menu that appears,
select Copy Here.
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Manage Icons in Kicker

You can add new programs to the control panel by right-clicking on
a free area of Kicker and then selecting Add Applet to Panel or Add

Application to Panel.

Right-click on a
free area of Kicker.

You can remove a program from the control panel by right-clicking its
icon in the control panel and then selecting Remove program name .

You can move icons in the panel by holding down the middle mouse button
or by choosing Move program name from the context menu.

Manage Icons in the KDE Menu

To make changes in your KDE menu, start the KDE Menu Editor by
selecting the KDE menu icon with a right mouse click and selecting Menu

Editor.
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The following appears:

In the left frame, you can see the
structure of your KDE menu.

There are three important icons in the toolbar:

Create new item

Create new submenu

Delete marked item

If you create a new item, you are asked to enter a name for the item.

Select when you
have entered a name.
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The right part of the window become active.

Select this button to choose
a new icon for the item.

In the Command text box, you can enter the path of the program you want
to start with this item in the future.

✍Exercise: Manage Icons in the KDE Environment
There is a program called “xlogo,” that simply shows the logo
of the X Window System. You will not find any icon or menu
entry of this program in KDE.

To view the functions of xlogo, use the command line which
can be started from the KDE menu via Run Command.

Enter xlogo in
the text box.

Select to execute the command xlogo.
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Create an icon to start the xlogo program

Z on your desktop

Z in Kicker

Z in the KDE menu

2.4.6 How to Use the Konqueror File Manager

Customize Konqueror

Almost all work in the file system can be carried out with the KDE

Konqueror program. To start Konqueror, select the icon in Kicker.
The following appears:

The most important icons in the toolbar are:

Go up one level Enlarge the icons

Go back to the last position Diminish the icons

Go forward (after back) Switch to icon view

Go to your home directory Switch to tree view

On the right side of the Konqueror window, you see the Navigation Panel.
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Clicking on these icons opens a new frame.

Start multimedia player Amarok Show bookmarks
Show history Show home directory

Show meta information Show network
Show root directory Show special services
Show important system directories

The icon on the navigation panel displays
the directory tree starting from the user’s home
directory.
The icon displays the directory tree start-
ing from the root directory.

You can use several methods to navigate through the file system. Using
the three arrows on the left side of the toolbar is the simplest way. The
current position is shown in the text box of the address panel (in the
following image, /home/geeko).

In the address panel, you can see
your position in the file system.

If you select , you will move from the current direc-
tory to the next higher directory (from /home/geeko

to /home). The arrow returns you to the previously
visited location. You can move forward again with .
Selecting in the toolbar takes you directly to your
own home directory (for example, /home/geeko).

Another method of navigating is provided by the navigation area. If you
select a directory in the navigation panel, its contents are displayed in the
file view.
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You can double-click the directory in the navigation panel to open it and
view all subdirectories contained therein. Double-click the directory again
to close it.

Another useful feature of Konqueror is its ability to split the window.

In the Window menu, there are Split View Left/Right and Split View

Top/Bottom options used to split the window.

The green light shows
the active view.

You can save your settings by selecting Settings→ Save View Profile

‘‘profile name’’.
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Here, you can enter
your profile’s name.

To switch to another profile, choose Settings → Load View Profile

and select a profile from the submenu.

✍ Exercise: Customize Konqueror
Look at the following Konqueror screenshot.

Rebuild it on your computer and save it as a profile labeled
“My Profile.”
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Manage the File System with Konqueror

Create Directories To create a new directory. Click in the white back-
ground of Konqueror with the right mouse button. A popup menu ap-
pears:

Select Create New → Folder

to create a new directory.

Alternatively, select Create New → Folder

from the Edit menu of Konqueror.

Then you are asked to enter a name for the new directory.

✍ Exercise: Create Directories
Create a directory labled FirstFiles in your home directory.
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Copy and Move Files

The explanation below for using files is also
valid for directories.

One way to copy or move a file is to drag and drop the
file icon from one Konqueror window into another.
If you hold Ctrl while moving the mouse pointer, the
file is copied.

Another way is to use the popup menu. Right-click the icon of the file
you want to copy and select Copy. If you want to move the file, select
Cut.

To copy and move several files at the same
time, hold down Ctrl while you are select-
ing files.

The items Cut

and Copy.

Now you can navigate to the directory you want to copy the file to. Right-
click in the white window background and select Paste from the popup
menu.
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You also can use
the shortcuts.

✍ Exercise: Copy and Move Files
Copy the file /usr/share/cups/calibrate.ppm into the di-
rectory ∼/FirstFiles/.

Rename Files To rename a file, right-click it, select the entry Rename

from the popup menu, and enter the new file name.

100 c©2007 Novell Inc. Copying or distributing all or part of this manual
is protected by a Creative Commons

Attribution-NonCommercial-ShareAlike 2.5 license.



2.4 Use the KDE Desktop Environment

You can also use the entry Properties to rename files. At the General

tab, enter the new name.

Enter the new
file name here.

✍ Exercise: Rename Files
Rename the file calibrate.ppm in the ∼/FirstFiles/ direc-
tory to first picture.ppm.

Delete Files You can delete files directly or by throwing them into the
trash.

Files thrown into the trash can be
restored before the trash is emptied.

To throw it into the trash, select Move to Trash from the popup menu.
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Before moving a file into the trash, Konqueror asks for confirmation.

You can also move a file into the trash by dragging the file with the mouse
onto the trash icon and then releasing the mouse button.

The trash icon on the desktop
changes as soon as it contains
something.

To view the content of the trash, double-click it. You can see the files
that have been moved there or you can even retrieve them.

A file thrown into the trash has not really been deleted, so it still takes
up hard drive space. To permanently remove or delete the items in the
trash, empty the trash.

To empty the trash, right-click the trash
icon on the desktop. In the popup menu,
select Empty Trash.
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Connect Files Using Links You can create a link by using drag and
drop. If you release the left mouse button after moving the mouse pointer,
a popup menu appears. To create a link, select Link Here.

A link differs from a normal file: The icon’s label is
emphasized (font italic).

Z – Normal file.

Z – Link.

❢ Attention! Be careful when deleting the original file. Do
not forget to delete the corresponding links. If the link is not
deleted, you will get an error message if you click it.

Copying, moving, renaming, and deleting links works in the same way for
both files and directories.

✍ Exercise: Connect Files Using Links

❶ Create a link to the file ∼/FirstFiles/

first picture.ppm in your home directory

❷ Rename the name of the link to first link

❸ Move ∼/FirstFiles/first picture.ppm to the trash

❹ Test what happens when you select the link

❺ Empty the trash

❻ Remove the link directly

c©2007 Novell Inc. Copying or distributing all or part of this manual
is protected by a Creative Commons

Attribution-NonCommercial-ShareAlike 2.5 license.

103



2 Understand the GUI Environment

Use the Linux File Permissions To see the file permissions, switch to
the tree view in Konqueror by selecting the icon.

Tree view shows Permissions,
Owner and Group.

To change the permission, right-click an icon, select Properties, and
activate the Permissions tab.

Use these menus to
change the permissions.
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✍ Exercise: Use the Linux File Permissions
Change the permissions of a directory ∼/FirstFiles/ that
only you have the permission to view and change the content.

2.4.7 How to Search for Files

Sometimes you have to find a file, but you do not know exactly where it
is in the file system. You might know the name of this file or only a part
of the name. You might need a list of all files that have been modified in
the last two days or that exceed a certain size.

To find files with specific features, select the KDE menu with Find Files.

In the Named field, enter the
name of the file you are
looking for.

Alternatively, you can start the search tool
directly from Konqueror by selecting Tools

→ Find Files.

If you do not know the whole name of the file, you can use the wildcards
“?” (for any character) and “*” (for none, one, or several characters).
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Enter the directory you
want to search in Look in.

You can also use the button to specify the directory you want
to search in. Select to start the search process. All matching
files and directories are shown in the lower window with details of their
locations.

All matching files
and directories.

Further settings can be made when you switch to the tabs Contents and
Properties.
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If you liked the live search from Beagle, you do not have to miss it when
using KDE. The KDE plugin that allows to use Beagle is called “Kerry.”

To start Kerry, select the search icon at the right in the KDE
Control Panel.

Enter what you are
looking for here.

Before you can use Kerry, you have to start Beagle. Enter something in
the Search textbox and press Enter or select . You will get
an error message, that your query failed. At the end of this error message
there is a link to start Beagle.
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Start Beagle here.

By selecting the option Automatically start Beagle daemon at

login Beagle is started automatically at login in the future. When Beagle
is started, searching for files and file content works quickly.

Specify what file type you
are looking for here.
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✍ Exercise: How to Search for Files
Start Beagle and search for “desktop.” Leave Kerry open and
start OpenOffice. In an empty spreadsheet enter KDE Desktop

Environment into a cell. Save the spreadsheet document un-
der the name “testspread” in your Documents directory.

2.4.8 How to Archive Files

With the program Ark, you can pack multiple files or even entire direc-
tories into an archive.

You can start Ark from the KDE menu by selecting Tools → Archiving

→ Ark (Archiving Tool). The following appears:

Before you start to archive files, create a new archive. Select File → New

to open a window to specify the archive’s path and name.
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When you select , an empty
archive is created at the given location.

Ark also handles the .zip format used in Microsoft Windows environments.
Ark supports a lot of file formats, e. g.:

Z Tar archives (*.tar, *.tar.gz, *.tar.Z, *.tar.bz2, etc.)

Z Compressed files (*.gz, *.bz, *.bz2, *.lzo, *.Z)

Z Zip archives (*.zip)

Z Lha archives (*.lzh)

Z Zoo archives (*.zoo)

Z Rar archives (*.rar)

Z Ar archives (*.a)

To fill the archive, drag the files you want to archive with the mouse from
Konqueror onto the empty window.

To open an existing archive (whether it is compressed or not), select the
file in Konqueror or start Ark and then select File→ Open. The contents
of the archive are displayed.

Using the mouse, you can drag individual files from the archive window
and place them in a Konqueror window. You can also unpack the entire
archive by selecting Action → Extract.
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Furthermore, you can use the icons in the toolbar:

– Create new archive

– Open archive

– Add file to archive

– Add directory to archive

– Extract selected file(s)

– Remove selected file from archive

– View the selected file

✍ Exercise: Archive Files
Create archives and include the content of the /bin directory.
Use the following file formats for these archives:

Z .tar.gz

Z .bz2

Compare the file size of the different archive types.

2.4.9 How to Customize KDE

To customize the KDE environment, use the KDE Control Center. It can
be started from the KDE menu by selecting Personal Settings.
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In the left frame, you can
see the available sections.

If you select one of the sections, the modules of this section are shown in
the left frame. On the top of the item list, you see the button that
brings you back to the main menu.

It is not possible to explain all functions of
the KDE Control Center here. But you are
invited to explore it for yourself.

We only will introduce some important modules and functions.

Appearance & Themes Section

Background Here, you can specify the background of your desktop.
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Select whether these set-
tings are valid for all virtual
desktops or only for one.

In the Background section, you can specify the background image.

In the Options section, you can define the position of an image, the
background color, or the type of blending if you want a slide show.

You can apply your changes by selecting .
To reset, select .

✍ Exercise: Change the Background
Select another background image.

Colors Here, you can change the colors of the window items.
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Here you can see a preview
of the selected color sheme.

You can select a full color scheme from the Color Scheme list or change
the color of a single window item (Widget) in the Widget Color section.

✍ Exercise: Change the Colors
Select another color scheme.

Fonts In this module, you can change the used font types.
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Icons In this module, you can change the icon set.

In a standard installation, there are
only two icon sets.
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Launch Feedback If you start an application, the icon of the application
bounces next to the mouse pointer to indicate that the application is
loaded.

You can configure this behavior here.

Screen Saver In this module, configure the screensaver.

There are a lot of screen savers avail-
able after a standard installation.

Splash Screen When you log into KDE, a splash screen indicates that
KDE is loaded.

In this module, you can select the splash screen.

Style Here, you can select the style of the KDE widgets.

Here you can see a preview
of the selected widget style.
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Theme Manager A desktop theme is a combination of the following
parts:

Z Background image

Z Color definitions

Z Widget Style

Z Icons

Z Fonts

Z Screensaver

Start the corresponding modules by selecting the buttons at the bottom
of the window.

Window Decorations
Select the style of the
window decoration (tab
Window Decoration)
and the style of the
buttons in the window
title (tab Buttons).

✍ Exercise: Change the Appearance of KDE
Configure KDE that it looks like Windows XP or Windows
95.
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Desktop Section

Behavior To configure a menu bar at the top of the screen (like the
Macintosh OS) and the behavior of KDE, click with a mouse button on
the desktop.

(De)activate tooltips.

In the tabs File Icons and Device Icons, you can activate icons for
special file types or devices at the desktop.
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Multiple Desktops

Specify the number of
the virtual desktops.

It is possible to label each desktop in the Desktop Names section.

Panels In this module, you can configure Kicker.

The dialog contains four tabs:

Arrangement – Position and size of Kicker

Hiding – Hide Kicker automatically

Menus – Add special menus to the KDE menu

Appearance – Add background images for the icons in Kicker

You are not limited to one panel in KDE.
To add further panels, right-click Kicker and
select Add New Panel → Panel.
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Taskbar The taskbar is available in Kicker and shows a list of the win-
dows from all desktops.

In this module, you can configure the taskbar and specify the actions:
Click the taskbar with your mouse.
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Window Behavior In this module, you can configure what will happen
if you double click the title bar of a window.

Focus – Microsoft Windows and Mac OS users are accustomed to
focus a window by mouse click. Some flavors of UNIX use
other methods. Here, you can select the focus policy.

Titlebar Actions – Here, you can change the actions for clicking a ti-
tlebar of a window with the mouse.

Window Actions – Here, you can specify a modifier key and the actions
of it.

Moving – In some cases, you used to see the content of a window when
it was being moved. If you have an older computer it could
be necessary to change this setting.

Advanced – Advanced features.

✍ Exercise: Change Window Behavior
Change the focus policy to Focus Follows Mouse. Open
some more windows and see the differences.
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Internet & Network Section

Briefly review some of the modules of the Internet & Network section
here, because going through them all would be out of the scope of this
course. For some of the modules you have to get root permissions.

This is an overview:

Web Browser – Configure the Konqueror web browser.

Desktop Sharing – You can allow access to your desktop via
the network.

File Sharing – Allow file sharing with Windows computers.
You need to be the system root user for this.

Local Network Browsing – View user information for accessing Win-
dows shares.

Proxy – Configure access to the Internet via Proxy.

KDE Components Section

We do not want to discuss all modules of the KDE Components section
here, because they are also beyond the scope of this course.
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Here is an overview:
Component Chooser – Choose your default mail client, text

editor, and terminal emulator

File Associations – Choose an application for each file type
to open the file

File Manager – Settings concerning appearance, behav-
ior, and preview of the Konqueror file
manager

KDE Performance – Minimize memory sage and configure
the preloading of Konqueror

KDE Resources – Configure resources for KDE

Service Mananger – Start and stop KDE services

Session Manager – Default settings for starting (log in)
and terminating (log out) a session

Spell Checker – Configure the spell checker
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Peripherals Section

Display Here, you can switch to another screen resolution and refresh
rate.

Geeko has changed the
display’s orientation.

If your hardware supports more than one
monitor, you can configure them in the tab
Multiple Monitors.
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In the tab Power Control you can select the time for standby, suspend,
and power off.

Keyboard Keeping a key on your keyboard pressed, after a short delay,
the output of the keyboard begins to repeat.

In this module, you can specify the delay and the rate of repeat.

Choose the state of the Num-
Lock key on KDE startup.
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Mouse The mouse module of the KDE Control Center contains four
tabs:

❶ General. Left handed people may prefer to swap the left and right
mouse buttons.

❷ Cursor Theme. There are some themes for the mouse pointer avail-
able.

❸ Advanced. Here, you can select some advanced features, e.g., the
pointer acceleration and the speed for double-click.

Be careful with these settings. It can be hard to hit
the button with a high speed mouse pointer.

❹ Mouse Navigation. To navigate the mouse pointer by using your
keyboard, enable it here.

Microsoft Windows uses double-
clicks to open files. KDE uses
single-clicks by default.

Printers This module helps to manage your printers.
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These are the avail-
able (pseudo) printers.

You can add, remove, and modify printers. You also can manage your
print jobs.

For a lot of functions, you have to be logged in as the root user, e.g., to
add a new printer or to change the configuration of a printer.

To get root permissions, select the
button.

You will learn to manage printers and print jobs later.

Remote Controls You need infrared hardware inside your computer to
use this module. Otherwise you get a notification.
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Regional & Accessibillity Section

Accessibility Functions for handicapped people.

Country/Region & Language Every region has its own standards for
formatting numbers, date, and time. In this module, you can select the
one you prefer.

Here, the current set-
tings are shown.

If you select your country from the Country or region menu, on the
Locale tab, the settings should be correct.

If you want to change the default settings, change them on the other tabs.

✍ Exercise: Change Region
Compare the standards for writing numbers, date and time of
three different countries. Compare North America, Europe,
and the standards of Asia.

Keyboard Layout Different regions use different keyboard layouts. In
this module, you can select the layout of your keyboard.
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Keyboard Shortcuts Here, you can configure keyboard shortcuts for
system actions.

The available system actions are classified into Global Shortcuts,
Shortcut Sequences, and Application Shotcuts.

Select an action from the list and activate the Custom option below. A
dialog appears.

Enter the key combination. Select to finish your input.

Security & Privacy Section

Crypto Configurations you need for encrypting and decrypting data.
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KDE Wallet KDE Wallet allows you to store your passwords and other
personal information on your disk in an encrypted file, preventing others
from viewing the information.

Password & User Account When you log in, your password is shown as
stars. In this module, you can configure how passwords should be shown
in general.

Privacy In this module, you clean your desktop environment from all
private information that is stored—e. g., by your web browser—on the
disk.

Sound & Multimedia Section

Sound System To access sound output
of other computers in your network or to
allow them to access your sound system,
activate it here.

System Bell If you enable system
notifications, KDE plays a sound file for
system messages.

In this module, you can deactivate the sys-
tem bell. The internal PC speaker will be
used instead. You can configure the vol-
ume, pitch, and duration of the system
bell.
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2.4 Use the KDE Desktop Environment

System Notifications In this module, you can configure sounds for a
lot of system events, e.g., the sound that is played when you get an email.

There are a lot of
event sources.

An event source can be a program.

In the white frame, the events for the selected source are shown.

The following actions are possible:

– Execute a command

– Send an error message to the default error channel

– Display a message box

– Write an error message to a log file
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– Play a sound

– Flash the taskbar entry of the application

System Administration Section

Font Installer Normal users are only allowed to install fonts for their
own private use. The root user can install fonts that are usable for all
users of the system.

Select this button to
install a new font.

Login Manager Here, the root user can configure the appearance and
funtionality of the Login screen.

Paths Specifies the path of important KDE directories:

Z Desktop path. Includes the item of your private desktop.
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2.4 Use the KDE Desktop Environment

Z Autostart path. The programs in this directory are started auto-
matically after logging in.

Z Documents path. When saving documents, this directory is set
as the default.
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SUSE Linux Enterprise Desktop 10 is a desktop product.
That means that much of the software included is for needs
in a office, such as word processing, email and presentations.

SUSE Linux Enterprise Desktop 10 based on the same code
like the SUSE Linux Enterprise Server 10. The server prod-
uct is delivered with software especially for server needs, e. g.,
DNS, DHCP, security tools

We want to introduce the software in this book to convince you of the
quality of open source software. If you are comfortable in using this
software, you can increase your productivity in school.

✍ Exercise: Use Open Source Tools
What kind of software typically runs on a server and what on
a desktop workstation? Consider five.

Software on Servers Software on Desktop
Workstations
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3.1 Use Firefox

An incredible amount of information is available on the world wide web
(WWW) (also called the Internet). You must have a web browser to access
the Internet and everything it offers. The Firefox web browser is one of
the more common web browsers and it is an open source applications.

After a standard installation of SUSE Linux
Enterprise Desktop 10, Firefox is your default
web browser. In this section you learn how to
use Firefox.

i The Firefox web browser was developed by the Mozilla Foundation.
You can find more information about Firefox and the development
process on the following web site: http://www.mozilla.org/

3.1.1 Understand the Firefox User Interface

Firefox looks a lot like the other major web browsers on the market.

Probably the most important part of the user interface is the address bar
where you can enter web page addresses (URLs).

Select or press Re-
turn to load the web page.
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Use the and to jump back to the previous page or forward to the
next page in the browser history.

Use to reload or refresh a web page.

Use to end the loading process of a page.

Selecting brings you dirctly to your default web page.

The text box at the far right of the toolbar allows you to use a search
engine (Google by default). Enter the words you want to search for and
press Return.

Select this triangle if you want
to change the search engine.

✍ Exercise: Understand the Firefox User Interface
Use the search text box in the Firefox toolbar to search for
Firefox’s share of the installed web browser market.

3.1.2 Use Tabbed Browsing

When you browse the web, you may need to open more than one web
site at the same time. Firefox offers tabbed browsing to help you manage
multiple open web sites.

With tabbed browsing, you can switch between open web sites by selecting
different browser tabs instead of opening and closing multiple windows.

Select to close
the active tab.
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You can open a new browser tab in three ways:

❶ Select File → New Tab from the menu bar

❷ Press the key combination Ctrl + T

❸ Select a link with your middle mouse button

✍ Exercise: Use Tabbed Browsing
Practice the three ways of opening a tab.

3.1.3 Use Bookmarks

Understand the Advantage of Using Bookmarks

If you find an interesting web site and you want
to be able to easily find it again later, Firefox
lets you store the web site’s address. A stored
web site address is also called a bookmark.

You can complete the following tasks with bookmarks:

❶ Set a Bookmark: Save the address of a web site

❷ Use a Bookmark: Use a stored web address to access a web site

❸ Manage Bookmarks: Sort bookmarks into folders

Set and Use Bookmarks

To save the address of the current web page, select Bookmarks →
Bookmark This Page from the Firefox menu bar or press Ctrl+D.
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The following dialog apears on the screen:

Select to add the
current address to the list
of bookmarks.

To access a stored web site address, select Bookmark in the Firefox menu
bar. Then select the bookmark for the web site you want to open.

Manage Bookmarks

If you set a lot of bookmarks in Firefox, finding a particular bookmark can
be difficult. To simplify the search, Firefox lets you sort your bookmarks
into folders.

Managing bookmarks in folders is similar to
managing files on your computer.

Firefox provides the Bookmark Manager to help you manage your book-
marks. To access the Bookmark Manager, select Bookmarks → Manage

Bookmarks from the Firefox menu.
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The icons in the Bookmark Manager are described here briefly:

Creates a new bookmark. A
dialog appears and you have
to enter at least a name and
a location.

Creates a new folder for bookmarks. A dialog appears so you
can enter a name for the folder.

Inserts a separator.

Moves bookmarks or folders. If you select a bookmark and
select Move a dialog appears and you can select a folder you
want to copy your item into.

Using drag & drop to move bookmarks and
change their order is easier.

Changes the name, location, or description of a bookmark.

Deletes the selected bookmark or folder.
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Use the Bookmarks Toolbar

Firefox provides a Bookmarks toolbar for quick access to your bookmarks.

The Bookmarks toolbar contains single bookmarks and bookmark folders.
Select a bookmark on the toolbar to load the corresponding web site.
Select a bookmark folder to see a list of the bookmarks stored in that
folder.

To access your bookmarks through the Bookmarks toolbar, add the book-
marks to the Bookmarks Toolbar Folder using the Bookmark Manager.

✍ Exercise: Use Bookmarks
Create a new bookmark folder in the Bookmarks toolbar and
add bookmarks to three of your favorite web sides.

3.1.4 Print Web Pages

Print a Web Page

Like other browsers, Firefox lets you print web pages. To print a page,
select File → Print from the menu bar, or press Ctrl + P .
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A print dialog appears on the screen:

The print dialog lets you change
the print settings for individual
print jobs. In the upper part
of the dialog, you can specify
which printer should be used.

In the middle of the print dialog,
you can specify which pages you
want to print (the print range)
and how many copies you want
to make.

The third part of the dialog lists three options for printing web pages or
parts of web pages that are made with frames:

Z As laid out on the screen. Print the web page as it is displayed
on the screen.

Z The selected frame. Print only the selected frame. You can select
a frame by clicking it.

Z Each frame separately. Print out each frame of the web page
separately.

You can start the print job by selecting .

✍ Exercise: Print Web Pages
Print something from your favorite web site.
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3.1.5 Manage Cookies

Understand What Cookies Are

Some web sites are personalized, which means that their content is espe-
cially adapted for your visit. The following is a list of some web sites that
are often personalized:

Z The web site you use to read your emails

Z The online shop where you order books or other products

Z The news web site which allows you to choose which kinds of news
stories you are interested in

Z The search web site which stores your personal preferences

Personalized web sites all have one requirement in common: they need
to be able to identify you. Otherwise, they would not be able to display
your emails, your ordered products, your site preferences, or whatever
personalized information or products they are offering.

One way a web site can identify you is by using cookies. A cookie is a
little piece of data which the web site stores on your computer. Each time
you return to this web site, the data is transferred to the site and used to
identify you.

Identify, in this case, does not necessarily mean
that the web site knows your name, your ad-
dress, or any other personal data. It means
that the computer or the browser installation
you are using is identified. Personal informa-
tion is handed to the web site only when you
enter it in a form and submit it to the site.

Understand the Risks of Cookies

Although cookies enable a lot of useful features, you have to understand
the risk associated with allowing them to be used.
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Whenever a web site sets a cookie on your
computer, everything you do on this web site
can be traced by the company or organization
which runs the site. This could affect your pri-
vacy, especially if you give your personal infor-
mation to the site. That personal information
could then be combined with the cookie.

Using cookies in a reasonable way is therefore an important part of secure
web browsing.

Manage Cookies

Firefox offers powerful cookie management features that you can use to
control how cookies are used on your computer.

You can manage cookies through the Firefox Preferences dialog. To open
this dialog, select Edit → Preferences from the menu bar.

To access the cookie management option, select Privacy at the
top of the dialog.
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3.1 Use Firefox

Then select Cookies

in the list on the right
side of the dialog.

Deactivate this option to
prohibit setting Cookies.

Select to remove all cookies.
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If you select you get a list
of all of the stored cookies, and you
can organize the cookies.

✍ Exercise: Manage Cookies
Count the number of cookies that are stored on your computer.

3.1.6 Delete Stored Data

Understand What Kind of Data Is Stored

Firefox stores several types of data when you are browsing web sites. The
following is an overview of these different types of data:

Z History. A list of visited web sites.

Z Saved Forms. Information you have entered into forms on a web
site.

Z Passwords. Passwords for web sites.

Z Download History. A list of downloaded files.

Z Cookies. Cookies that have been set by web sites.

Z Cache. Web site data which is stored to save network bandwidth.
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Understand the Risks of Stored Data

In general, the fact that Firefox stores data is
not a problem. Stored data can enhance Fire-
fox’s performance when you are browsing web
sites. However, you have to make sure that the
stored data is not misused.

The following list contains some examples of when the stored data could
be at risk of being misused:

Z You share one computer account with other people.

Z You cannot trust the administrator of a computer (in an Internet
Cafe, for example).

Z You do not want a web site owner to use cookies to trace your visits
to the web site.

Z Another person is sitting at your computer (browser history).

Delete Stored Data

Firefox allows you to delete all kinds of stored data. Select Edit →
Preferences from the menu bar. In the Preferences dialog, select
Privacy on the left side.
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On each tab, you can
delete the stored data.

Alternatively, you can select Clear Private Data from the Tools menu.

3.1.7 Handle SSL Connections

Understand What SSL Is

Usually, the data which is transferred to and from the web browser is not
encrypted. Anyone with the right technical equipment and knowledge
could intercept and read the transferred data.

In some cases, you need to send or receive data
that shouldn’t be intercepted, like passwords
or credit card information. To prevent unau-
thorized access, you must encrypt the data.
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The following is a list of some of the situations
in which encryption is strongly recommended:

Z You are reading email through a web site.

Z You are doing online banking.

Z You are requesting confidential docu-
ments from your company’s intranet site.

Firefox uses a technology called Secure Socket Layer (SSL) to encrypt the
tranferred data.

Understand How Firefox Handles SSL

If a web site offers an encrypted connection, Firefox displays a dialog
which indicates that the connection is encrypted.

Firefox indicates that you are on an encrypted web site by the following
hints:

❶ The background color of the address bar changes to yellow.

❷ A lock icon is displayed at the end of the address bar.

❸ A lock icon is displayed at the bottom left corner of the window.
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3.1.8 Install Themes

To change the appearance of Firefox, you can download themes from the
Internet and install them locally.

To do this, select Tools → Themes. A dialog appears.

Here, the installed
themes are listed.

If you select Get More Themes, a Firefox window opens and shows a
mozilla.org’s web site, from where you can download a lot of themes. On
each theme description, you will find a link Install Now. If you select
this link, Firefox asks for confirmation.

To downloaded the theme file, select the new theme in the list of themes
and select . You have to restart Firefox to activate the new theme.

To uninstall a theme, select .

If you want to look for a newer version of an installed theme, select
.

✍ Exercise: Install Themes
Install a new theme and change the appearance of Firefox.
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3.1.9 Install Extensions

There are a lot of extentions for Firefox. Using extensions, you can add
powerful functions to the web browser, like a preview for search engines.

To do this, select Tools → Extensions.

The dialog is similar to the theme dialog.

Select Get More Extentions to get a list of available extentions from
mozilla.org.

Some extentions allow configuration. In this case, is activated.

✍ Exercise: Install Extensions
Install and test an extention.
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3.2 Use OpenOffice.org

OpenOffice is the most used office software on Linux. With OpenOffice,
you can do the following:

Z Create and edit text documents

Z Calculate and manage data in spreadsheets

Z Create and deliver presentations

Z Create paintings and illustrations

You may have worked with other office suites such as Microsoft Office.
OpenOffice provides you with a similar set of tools and features to help
you complete your work.

OpenOffice is not included on the SUSE Linux Enterprise Server, because
you normally do not use office software on a server.

OpenOffice is based on a software program called StarOffice, which was
developed by Star Division, a German software company. A few years
ago, Sun Microsystems acquired Star Division and released StarOffice as
open source software.

The software was renamed to OpenOffice and the OpenOffice organization
was founded. OpenOffice manages the development process of OpenOffice
and works, together with the worldwide OpenOffice developer community,
on further improvements.

From time to time, Sun Microsystems adds some new components to
the current OpenOffice version and then releases this modified version
under the name StarOffice. OpenOffice and StarOffice files are completely
compatible and can be exchanged without any problems.

i For more information about the development of OpenOffice, or
to download the latest version, visit the OpenOffice website:
http://www.openoffice.org
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3.2.1 Basics about OpenOffice

Understand the Components of OpenOffice

OpenOffice can be used to complete many different tasks. OpenOffice is
split into several sub-applications, each of which is used for a dedicated
task.

The following table lists these OpenOffice sub-applications and gives a
brief description of their functions:

OpenOffice Base Create databases similar to Microsoft Ac-
cess

OpenOffice Calc Create spreadsheets similar to Microsoft
Excel

OpenOffice Draw Draw pictures and create illustrations
OpenOffice Impress Create and deliver presentations similar to

Microsoft PowerPoint
OpenOffice Math Create complex mathematical formulars
OpenOffice Writer Write text documents, reports, and letters

similar to Microsoft Word

By default, there is a
launcher for OpenOffice
Writer in the main menu.
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Understand the OpenOffice File Formats

OpenOffice uses the OpenDocument file for-
mats approved by OASIS – the standards body
for XML data formats in business; OASIS is
sponsored by all the leading names in the com-
puting industry, including Microsoft. Open-
Document is a genuine, vendor-neutral, open-
standard specification, free from intellectual
property challenges.

Each file type has a different file extension. The following table lists each
file type and its associated OpenOffice application and file extension.

File Type OpenOffice Application File Extension
Text File OpenOffice Writer .odt
Spreadsheet File OpenOffice Calc .ods
Presentation File OpenOffice Impress .odp
Drawing File OpenOffice Draw .odg
Database OpenOffice Base .odb

OpenOffice can import and export most important formats of other office
suites, allowing you to collaborate and exchange documents with people
who are not using OpenOffice.

3.2.2 Get Help and Support

If you need to find out how to use a particular feature of OpenOffice, but
neither your friends nor the teacher can help you, you can use the built-in
help system or online OpenOffice resources.
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Use the OpenOffice Help System

You can reach the integrated OpenOffice help system by selecting Help→
OpenOffice.org Help from the menu bar. The OpenOffice help system
opens up in a separate window.

The help text is displayed in the right-hand frame. The help pages are
cross-referenced with links, just like web pages. The left-hand frame offers
four tabs for finding information about the topic of interest:

Contents – This tab features a table of contents with all of the chapters
available for help.

Index – This tab features keywords like an index of a book. A search
function helps you find a keyword.

Find – This tab lets you search the contents of all help chapters for
specified terms.

Bookmarks – Use the icon to the far right to mark interesting help pages
with a bookmark. The tab Bookmarks lists all previously
set bookmarks.

Know the Help Agent

OpenOffice features a context-sensitive help function. Certain actions
activate the Help Agent in the lower right corner of the application.
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You can also select the im-
age of a light bulb to get
context-sensitive help.

Use the OpenOffice Web Forum

The OpenOffice Help System contains a lot of information that can help
you solve many kinds of challenges that may occur when you use OpenOf-
fice. However, in some cases, the interaction with other users is much more
efficient.

i You can go to the website http://www.oooforum.org. This site
hosts many web forums where you can discuss questions and chal-
lenges with other OpenOffice users.

An overview of the available forums appears on the start page of the site.
You can read the forums for free. If you want to post your own questions
or respond to someone, you need to set up a free account by selecting the
Register link in the upper right corner of the start page.

3.2.3 Customize OpenOffice

The configuration of OpenOffice can be done by Tools → Options.

The available options vary
between the OpenOffice
components.
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Menus, keyboard shortcuts and toolbars can be customized via Tools →
Customize.

3.2.4 Work with Text Documents

We will start with OpenOffice Writer, because
this will be the component you use the most.
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Create a New Text Document

By default, OpenOffice Writer opens a new text document. You can start
creating text in the new document immediately. To create another new
document, select File → New → Text Document from the OpenOffice
menu bar.

You can also select the first
icon in the toolbar to create a
new text document.

Save a Text Document

When you create or modify a document in OpenOffice, you need to save
it using one of the following commands from the File menu:

Save As – This command lets you name your document and select a file
type for it.

Save – This command lets you save changes to an existing document
(a document that has been saved before in OpenOffice).

You can also press the key combination Ctrl + S to save a
file or click on the floppy disk icon in the toolbar.

The Save As command opens a dialog that allows you to enter a file name
and select a file type.
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If the option Automatic file name

extension is checked, the .odt exten-
sion is automatically added to the file
name you have typed in.

The first time you save a new document, Save
also opens the Save As dialog. After that, you
can use Save to write your changes to the file.

You can also choose a file location and a file type for your document. By
default, files are stored in ∼/Documents/.

The following is a list of the most important file types supported by
OpenOffice. All file types are listed, if you open the File type menu in
the Save dialog:

OpenDocument Text. Native file format for OpenOffice. You should
always save one copy of your document in this format to make sure
that your document formatting is saved correctly. The file extension
is .odt.

OpenOffice 1.0 Text Document. Native file format for old OpenOffice
versions. The file extension is .sxw.

Microsoft Word 97/2000/XP. Text document type of the current ver-
sions of Microsoft Word. Use this file format to exchange text doc-
uments with Word users. The file extension is .doc.
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Rich Text Format. File type that can be opened by many word proces-
sors. It is a good choice when you need to exchange documents
with someone, but you are not sure which word processor the other
person uses. The file extension is .rtf.

Text. Stores documents in plain text. Other elements, such as images
and formatting, are not saved. This is the simplest way to store a
text document. The file extension is .txt.

OpenOffice is able to create PDF files without installing an exter-
nal PDF creator. You can create a PDF file of your document by
selecting the icon in the toolbar or selecting Export as PDF from
the file menu.

In most cases you should use PDF files when
you send a document to others.

To close a document after you have saved it, select File → Close. To
exit OpenOffice Writer completely, select File → Exit.

✍ Exercise: Work with Text Documents – Part 1
What are the benefits of PDF?

•

•

•

•

•
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In which cases does it not make sense to give your friend a
PDF file?

Open a Text Document

To open a text document, select
File → Open from the menu
bar. OpenOffice displays the
Open dialog.

The Open dialog lets you browse
the file system for files.

You can open any file type (not just word process-
ing files) that can be used in any OpenOffice program.
OpenOffice then opens the appropriate OpenOffice pro-
gram for the file you selected.

Alternatively you can
select the folder icon
in the toolbar.

✍ Exercise: Work with Text Documents – Part 2
On the CD with your course materials, in the directory
examples/OpenOffice/ you find a file loremipsum.odt.
Open this file and save it in Microsoft Word format.
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3.2.5 Understand the Structure of Writer Texts

Before you start writing with OpenOffice writer, you have to know how
text is stuctured in Writer.

The smallest unit of text is a character. The biggest unit of text is a
document. Between document and character there are some more units:

❶ Character. A character

❷ Word. One or more characters build a word. In most cases, a word
is separated by white spaces.

❸ Paragraph. Several words build a paragraph. A new paragraph
always starts on a new line and finishes with a line break (also known
as a “hard return”).

❹ Frame. A frame normally contains of something that is not in-
cluded into the textflow, like a graphic, or a formula.

❺ List. Two or more items. Each new item is introduced by a bullet
point or a number.

❻ Page. Equivalent of one sheet of paper.

❼ Document. The whole text.
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Change Character Formats

The most common character formats are available in the OpenOffice for-
matting toolbar.

Z Select a font from the pull-down menu

Z Select a font size from the pull-down menu

Z Enable/disable bold font weight

Z Enable/disable italic font

Z Enable/disable underline

Z Select a font color from the pull-down menu

Z Select a background color from the pull-down menu

If you select Format → Character a dialog appears from which you can
select more character formats within the tabs.
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Here you can see
a preview.

You can adjust the font properties before you
start writing. You can also change the font
properties of existing text by selecting the text
first and then adjusting its font properties.

✍ Exercise: Change Character Formats
Change the font in the file loremipsum.odt to Lucida Sans.

Change Paragraph Formats

Some formats refer to paragraphs and not to characters, e.g. alignment.

For the most important paragraph formats there are icons in the format-
ting toolbar available.

– Style of the paragraph

– The lines of the paragraph are aligned to the left

– The lines of the paragraph are centered

– The lines of the paragraph are right aligned

– The lines of the paragraph are filled with whitespaces
so that they build a block
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– Numbered list

– Bullet list

– Decrease indent

– Increase indent

– Select a background color from the pull-down menu

When you change a setting, it affects the paragraph
in which the cursor is currently positioned.

For more detailed para-
graph settings, activate
Format → Paragraph. A
dialog appears and you
can specify indents, bor-
ders, and much more.

Use Lists

Lists are special kinds of paragraph formats. OpenOffice supports two
different kinds of lists:

Z Numbered Lists: In these lists, every item starts with a number.

Z Bulleted Lists: In these lists, every item starts with a bullet point.

You can activate the List function using the list buttons or in the
toolbar.
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After you have activated the list function for a paragraph, a new item is
inserted whenever you press the Enter key. To disable the list function,
select the corresponding list button again.

You can change the way
a list looks by selecting
Format → Bullets and

Numbering. In the Num-
bering/Bullets dialog that
appears, select a numbering
or bulleting scheme for your
list.

OpenOffice creates a list automatically if you start a new paragraph with
1. (for a numbered list) and -, * or + (for a bullet list). You can de-
activate this option by selecting Tools → AutoCorrect → Options and
deactivating the option Apply numbering - symbol:•.

Use Tabs and Indents

One important paragraph formatting tool is tabs. You can use tabs to
align text in columns. There are four types of tabs available.
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Icon Alignment Example

left

right

decimal

center

Here you can select
the type of tab.

To set a tab perform the following two steps:

❶ Select the type of tab.

❷ Position the tab in the horizontal ruler.

In the text press Tab to jump to the next tab stop.

To delete a tab, select it with the mouse and
release the mouse button when you are out of
the horizontal ruler.

By default OpenOffice Writer sets a left alignment tab stop every 0.49”.
These tab stops are removed automatically if you set your own.
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This is the mark for
a default tab stop.

In the horizontal ruler there are some more icons:

❶ The first line indent:

The left indent of the first
line of the paragraph.

❷ The before text indent:

The left indent of
the paragraph.

❸ The after text indent:

The right indent of
the paragraph.

Use Defined Paragraph Styles

The leftmost pulldown menu in the formatting
toolbar includes a list of predefined paragraph
styles.

These styles include definitions for font, font
size, typeface, indents, spacing, line spacing
and more.
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Default represents the default style. The other
styles are based on the default style.

The heading style should be used for headings.
Heading 1 is the top level heading. Heading

2 the second level heading and Heading 3 the
third level heading.

Text body should be used for the text body.

If you select More from the pulldown menu,
the Stylist dialog appears. We will explore
this dialog later.

Using styles for headings has a lot of advantages:

Z You need only one mouse click to format headings.

Z You do not need to keep in mind the font attributes of your headings.

Z OpenOffice can use these styles to create a Table of Contents auto-
matically.

✍ Exercise: Use Defined Paragraph Styles
Change two paragraphs of the file loremipsum.odt to
Default and the first line to Heading 1.

Change Page Settings

When you are working with a text document, you will often need to
modify the document’s page setup. The most important page parameters
that you can change in OpenOffice are listed below:

Z Paper format

Z Page margins

Z Headers and footers

Z Page background

Z Page borders

Z Text columns
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To change a page setting, select Format → Page. The Page Style dialog
appears:

The dialog includes
several tabs.

Use the Stylist

You can start the Stylist by selecting the very left icon in the
formatting toolbar.

The Stylist shows all defined styles in
a separate dialog. Use double-click to
assign a style. The styles are grouped.

– Paragraph styles

– Character styles

– Frame styles

– Page styles

– List styles
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Furthermore you can use the pulldown menu at the bottom of the dialog
to filter the defined styles.

The fill icon ( ) can be used to “pour” the selected format into the text.
Select the icon a second time to deactivate the fill mode.

The icon at the very right ( ) can be used to create new styles. Open
the menu. You have three possibilities:

❶ New Style from Selection. Enter a name for a new style. The
new style contains the formats of the selection in the text.

❷ Update Style. The formats of the selected style are overwritten
with the formats of the selected text.

❸ Load Styles. Import a style from another template or file.

Styles are stored in a template file. You
can create a new template if you save a file
as the file type OpenDocument Text Template

(.ott)

✍ Exercise: Use the Stylist
Create a new paragraph style from a paragraph you changed
the font to Lucida Sans. Label this style “Body Sans”.
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Change all paragraphs (except the heading) of the file
loremipsum.odt to style “Body Sans”.

✍ Exercise: Work with Text Documents
Create your private letterhead with your name, your address
and your telephone number.

The default font should be Lucida Sans in size 14.

Save your template as OpenDocument Text Template

(.ott)

3.2.6 Adjust the Zoom Factor

With the zoom factor, you can control the scale (100%, 75%, 150%, and so
on) with which a document is displayed in the OpenOffice Writer window.
For example, you might want to view the document layout on a different
scale (50%) than the scale you would use to enter text (100%).

You can control the zoom factor in OpenOffice by opening the zoom menu
in the toolbar.
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Alternatively, you can control the zoom
factor by right-clicking on the status bar
at the bottom of the program window.

You can specify the zoom factor as a percent value (such as 150% or 75%)
of the original size of the document, or you can select one of the automatic
settings. The following settings are available:

Optimal – Adjusts the zoom factor automatically so that it’s opti-
mal for entering text.

Page Width – Adjusts the zoom factor so that you can see the whole
width of a page.

Entire Page – Sets the zoom factor so that you can see the entire page.
This setting is also useful when you want to check the
layout of a page or several pages at one time.

3.2.7 Enable the Spell Checker

The spell checker in OpenOffice Writer helps you identify misspellings in
your text documents.

You have two possibilities when using the spell checker:

❶ Activate the AutoSpellcheck icon in the toolbar.

When the spell checker is enabled,
OpenOffice marks every misspelled word
it finds, is underlined in red.
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To fix a misspelled word in a document,
right-click the word. The spell checker
will suggest the correct form of the word
in a pop-up menu. If you select the cor-
rectly spelled word in the pop-up menu,
the misspelled word will automatically be
replaced by the correct one.

❷ You can enable the spell checker by selecting Tools → Spellcheck

or the Spellcheck icon in the toolbar.

A dialog appears:

Suggestions made by
the spell checker.

3.2.8 Insert Image Files

Writers often add image files to their text documents. To insert an im-
age, select Insert → Picture → From File. The Insert Picture dialog
appears. It allows you to select an image file from your hard disk.
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Select this option for
activating preview.

If you select the option Link, the graphic file itself is not included in the
OpenOffice file. This is useful if the graphic file is very large. If you do
not select Link, the graphic file will be included in the document. This
allows you to share your document with other people.

After you select a file, click Open. The graphic will be inserted into the
document. You can change the size of the image by selecting and moving
the border of the image. Hold down the Shift key while resizing the image
to ensure that the width-to-height ratio of the image is not changed.

After you have inserted an image file, you can determine how the image
is integrated into your text document. For instance, you might want to
change how the image is anchored to the page (where it appears on the
page) and how the text flows around the image.
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When you select an image with a left
mouse click, green dots are displayed
around the image. If you now right-
click the selected image, a context
menu appears. This menu allows you
to configure several image settings.
When you move the mouse over the
Anchor entry, a sub-menu appears. It
lists several options for anchoring the
image on the page.

The anchoring options are explained below:

To Page – Anchors the image to the current page. No matter what
you do with the text on the page, the image stays on
this page.

To Paragraph – Anchors the image to the current paragraph. When the
paragraph is moved, the image moves, too. This is the
default setting.

To Character – Anchors the image to the currently selected character.

As Character – Interrupts the text flow at the position where the image
is inserted.

You can also configure how the text flows around the image. Right-click
the image. Select Wrap from the pop-up menu that appears.
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The Wrap options are explained below:

No Wrap – The inserted image splits the text into two para-
graphs (above and below the image). No text will
appear to the left or right of the image.

Page Wrap – The text flows around the image on the left and
right sides.

Optimal Page Wrap – Similar to Page Wrap, but OpenOffice decides
how the text is wrapped.

Wrap Through – The text continues behind the image and is not
interrupted.

In Background – The text flows over the image instead of behind
the image.

Contour – Trys to detect the contour for wrapping the text
around the image.

Edit Contour – Opens a dialog that allows you to define an exact
contour for wrapping the text around the image.

First Paragraph – Starts a new paragraph below the object after you
press Enter .

c©2007 Novell Inc. Copying or distributing all or part of this manual
is protected by a Creative Commons

Attribution-NonCommercial-ShareAlike 2.5 license.

177



3 Use Open Source Tools

3.2.9 Insert Tables

A table allows you to display information in a text document in a struc-
tured form. To insert a table in OpenOffice, select Insert→ Table. The
Insert Table dialog appears. It allows you to configure the table.

The Columns and Rows fields are the most important fields in this dialog.
You can specify how large your table is going to be. After you have
defined your table and selected , the table is inserted into the
document.

To add text to a table, you simply select a field and type in the text. You
can format the text just as you would regular text in the document. If
you right-click in a field, you can format the text in that field with the
menu that appears.

To format more than one field at once, select multiple fields by clicking in
one field and then moving the mouse over the table while holding down
the left mouse button.
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When you select a table or a cell
in a table, a new toolbar ap-
pears.

The most important tools are:

– Create new table

– Style of the lines

– Color of the lines

– Borders

– Background color

– Split cell

– Align cell content at the
top

– Center cell content verti-
cally

– Align cell content at the
bottom

– Add new line

– Add new column

– Remove line

– Remove column

– Table properties

3.2.10 Embed Other Office Documents

To embed another OpenOffice document (e.g., an OpenOffice Draw im-
age) in a text, select Insert → Object → OLE Object. The Insert OLE
Object dialog appears. OLE is also a very old concept, and stands for
Object Linking and Embedding. It asks you what kind of object you want
to embed.
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You can select Create new or Create from file. If you select the
Create from file option, you can load and embed existing OpenOffice
documents.

Object type lists the available object types corresponding to the docu-
ments that can be created with OpenOffice.

After you have embedded a document, you can edit the embedded docu-
ment by double-clicking it.

3.2.11 Embed Table of Contents

If you use the styles Heading 1, Heading 2 and Heading 3 in your docu-
ment, it is easy to let OpenOffice create a Table of Contents.

Select Insert → Indexes and Tables → Indexes and Tables.

Preview of the ta-
ble of contents.

The dialog has five tabs:

Index/Table – From the Type pull-down menu you can select what type
of index or table you want to create.
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Entries – With Structure you can configure the structure of the
entries for each level. The following abbreviations are
used:

E# Chapter number

E Entry text

T Tab stop

# Page number

LS Hyperlink

Use the five buttons below to change the structure. To
delete an element press Del .

Styles – Select a paragraph style for each level.

Columns – If you want a more than one column layout for your table,
you can select it here.

Background – Select the background color.

If you do not deactivate the option Protected against

manual changes in the Index/Table tab, it is not
possible to modify the Table of Contents manually.
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The table of
contents.

3.2.12 Print Text Documents

Learn About Basic Print Procedures

Printing a text document in OpenOffice is
simple. In some cases, however, you might
need to change some printing options to get
the results you want.

The basic procedure for printing a text document in OpenOffice is ex-
plained below:

❶ Save your document before you print it.

❷ Select File → Print from the menu bar. A Print dialog appears
on the screen.
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❸ You can change three different settings in the Print dialog:

Z The Printer that will be used to print the document

Z The Print range of pages that will be printed

Z The Number of copies that will be printed

❹ Select to start the printing process.

The OpenOffice Print dialog lists the printers that are currently installed
in your system.

Change Printer Properties

Depending on the printer model, you can adjust some printer settings
in the OpenOffice Print dialog. Select on the Print dialog.
The following is a list of the options that commonly appear on the Print
dialog:

Z Paper size. Which paper size (like U.S., Legal, or A4) the printer
will be printing on.

Z Paper tray. Which tray the printer should use as the paper source.

Z Scale. Whether the document will be printed at 100% or in a
reduced size.
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The options that you see depend on the
printer that is installed in your system.

Use the Print Preview Feature

OpenOffice lets you preview your document before you print it, so you
can see how it will look when it is actually printed on paper. To preview
your current document, select File → Page Preview.

When you have finished previewing your document, select from
the preview toolbar again to return to the normal edit mode.
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3.3 Work with Spreadsheets

A spreadsheet is basically a large table in which you can enter differ-
ent kinds of data. This data can be text, numbers, prices, or anything
else that can be processed by a computer. In spreadsheet programs like
OpenOffice Calc, you can use formulas to process the data you have en-
tered. This makes a spreadsheet program a very powerful tool for all
kinds of data processing.

The following is an example of how a spread-
sheet could help you in your daily work. Sup-
pose you want to create a table about the
whereabouts of your allowance. This table con-
tains several positions.

It sometimes makes sense to have a sum of all
positions at the end of the table. In this exam-
ple, you could add all positions manually and
type in the sum at the bottom of the table. If
you use a spreadsheet program, however, you
can solve the problem in a more convenient
way. Simply add a formula to the spreadsheet!
The formula then sums up the positions and
writes the result in the field at the bottom of
the invoice.

Another advantage to using a spreadsheet: If you change one of the prices,
the sum is automatically recalculated and adjusted.

3.3.1 Start OpenOffice Calc

You can start OpenOffice Calc by selecting OpenOffice.org Calc from
the Office group in the Application Browser. After a while the Calc
window appears on the screen.
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If you have already opened another OpenOffice window, you can select
File → New → Spreadsheet from the menu bar in OpenOffice.

3.3.2 Work with Multiple Sheets in One Document

Each OpenOffice Calc document contains several spreadsheets. You can
switch between these sheets using the spreadsheet tabs at the bottom of
the Calc window.
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If you right-click a spreadsheet tab, the following menu appears:

This menu allows you to complete the following tasks:

Insert Sheet. Adds a sheet to the current document. You can give the
new sheet a name and decide whether it’s inserted before or after
the current sheet.

Delete Sheet. Removes the currently selected sheet from the document.

Rename Sheet. Allows you to rename the current sheet.

Move/Copy Sheet. Allows you to move the current sheet to a different
position in the tab list.

Select All Sheets. Selects all sheets in the document. Then, any
changes (like formatting changes) made to one sheet are also ap-
plied to all other sheets. To deselect a sheet, click on its tab while
holding down the Ctrl key.

Save and Open Spreadsheet Files

OpenOffice Calc files use the .ods file name extension. To save a file,
select File → Save As, File → Save, or . To open a file, select File
→ Open or . The Open and Save dialogs in OpenOffice Calc are very
similar to the dialogs in OpenOffice Writer.
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OpenOffice Calc can import and export Microsoft Excel files. Opening
and saving these Excel files in OpenOffice Calc is simple. To export your
OpenOffice Calc document, you simply select the Excel format in the Save
As dialog.

When you create an Excel spreadsheet in
OpenOffice Calc, you should always save one
copy in the .ods format to make sure that all
formatting is saved correctly.

Use Your Excel Knowledge

If you have worked with other spreadsheet programs such as Microsoft
Excel, you will see that the basic concepts are the same in OpenOffice
Calc. With very few exceptions, Calc can do everything that Excel can do,
but sometimes Calc accomplishes a task in a different manner. However,
most of your knowledge about spreadsheets can be reused when working
with OpenOffice Calc.

3.3.3 Enter and Format Data

Entering data into a spreadsheet is easy. Simply select a cell with a single
click and start typing data. The data you are typing appears on the screen
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in two locations: in the cell itself and in the formula input line above the
spreadsheet.

Select this button to
accept your input.

❢ Attention! Calc distinguishes cell content between two data
types: numbers and text. With numbers Calc is able to com-
pute. With texts not. Using number formats you can append
characters to a number (e.g., a currency sign).

You can format the data using the Format bar of OpenOffice Calc.

The options in the Format bar are similar to those in OpenOffice Writer.
The options include font family, font size and face, and alignment of the
data in the spreadsheet cell.

Some new icons are introduced here:

– Merges the selected cells to one cell

– Adds the default currency symbol behind a number

– Adds a percent symbol behind a number

– Resets to the default number format

– Adds a decimal place to a number

– Removes a decimal place

– Specifies the border for the selected cell(s)

– Specifies the background color for the selected cell(s)

– Specifies the font color for the selected cell(s)
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When the data is too large for a cell, you can adjust the width of the
column by selecting the right column border in the column header and
moving the border while holding down the mouse button.

Select this line to
resize column A.

Resizing rows works in the same way: select the lower line border in the
line header.

You can access advanced cell formatting options by right-clicking a cell.
Select Format Cells in the pop-up menu that appears to access several
advanced formatting options. (You can format more than one cell at a
time by marking multiple cells.) Alternatively you can select Format →
Cells.

To edit the existing content of a cell, double-click the cell. Then you can
position a cursor in the cell and make your changes. Instead of double-
clicking the cell, you can just select the cell and then edit its content in
the input line.
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Adjust Data Types

An advantage of defining the data types correctly is that
OpenOffice can format the data correctly. In the example,
the price is displayed without a currency symbol such as “$”
or the Euro symbol, so you don’t have enough information.

To format the cell containing prices, right-click the cell and select Format
Cells. The Format Cells dialog appears:

Here you can
see a preview.

To configure the data type that will appear in the selected cell, make sure
the Numbers tab of the dialog is selected.

You can select a data type from the Category list of data types in the
upper left corner of the dialog.

Under Format, you can select the format of the selected data type.

As with all formatting, you can apply the data type to more than one
cell at a time by selecting multiple cells before starting the Format Cells
dialog.
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✍ Exercise: Enter and Format Data
Create a spreadsheet containing your school time table and
class schedule. Use different fonts, alignments, borders and
colors.

3.3.4 Work with Formulas

Address Spreadsheet Cells

To work with data in a spreadsheet, you must be able to refer to a par-
ticular cell in the spreadsheet. If you could not specify a particular cell,
how could you enter a formula which says, “Take the values from cells x
and y and write the sum in cell z”?

Spreadsheet programs identify each column with a letter and each row
with a number. Each cell can therefore be identified by a letter/number
combination. The cell B2, for example, is in column B and row 2.

Here the address of the
selected cell(s) is shown.

Understand the Formula Syntax

A formula can basically be seen as a box that processes input from other
cells and displays the result. OpenOffice Calc provides many different
kinds of formulas for all kinds of data processing. Each formula has
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a unique name. For example, the formula that sums up the values of
multiple cells is called “SUM”.

To use a formula, you must first select a
cell to which the result of the formula can
be written.

Then you can start defining the formula
with =formula name . In the example,
this would be =SUM.

Each formula needs to be told which cells should be processed. You need
to identify the parameter(s) of the formula. In the example, the SUM
formula needs to know which cells it should sum up. The parameters are
added to the formula in parentheses after the formula name.

In the example, the SUM function needs to know which cells contain the
information that is to be summed up. One way to provide this information
is to type each cell address, followed by a semicolon.

=SUM(A2;A3;A4;A5;A6)

This formula would sum up the cells A2, A3, A4, A5, and A6. If the
input cells are numbered sequentially, you can specify them using the “:”
character.

=SUM(A2:A6)

The =SUM(A2:A6) formula will sum up the
values in cells A2 to A6. After you have
entered the formula, press Enter to display
the result in the target cell.
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SUM is one of the most common formulas.
Therefore, there is a icon for SUM on the left
of the formula input line. Select and then
you can select the cells using the mouse.

Use Basic Arithmetic

Instead of using pre-defined formulas such as SUM, you can use basic
mathematical operators (“+”, “-”, “/”, and “*”) in a spreadsheet. The
following list explains how to use these operators:

Z +. Adds two cell values. For example: =D6+F8

Z -. Subtracts one cell value from another. For example: =E4-F5

Z /. Divides two cell values. For example: =A3/D4

Z *. Multiplies two cell values. For example: =F5*F6

You can also combine multiple operators in one expression. For example,
you could specify =C7+C8/F6.

Be aware that OpenOffice processes division
and multiplication operations before addition
and subtraction operations. Thus, if you spec-
ified =C7+C8/F6, C8 would be divided by F6
and the result would then be added to C7.

You can use parentheses to change the order in which operators are pro-
cessed. The operations inside the parentheses are processed first, and
thereafter the operators outside the parentheses are processed. For exam-
ple, if you specified =(C7+C8)/F6, C7 and C8 would be added first and
the result would then be divided by F6.
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3.3 Work with Spreadsheets

Use the Functions AutoPilot

OpenOffice Calc provides hundreds of formu-
las for all kinds of purposes. If you have used
other spreadsheet programs, you should not
have any problems using the formulas in Calc.
OpenOffice Calc provides a Function Wizard
to help you browse and use the available
formulas.

To use the Function Wizard, select the target
cell for the function; then select in the tool
bar.

You can pick a formula from the Functions tab on the left side of the dia-
log. First, you can choose a category from the Category drop-down menu
to narrow the formula search, or you can browse all available formulas by
selecting All.

A description of the
selected function is
displayed here.

If you select or double-click a function, the AutoPilot shows
you input fields for parameters that can be used with the selected formula.
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The input fields for
the selected function.

You can fill in the fields manually or you can select areas in the spread-
sheet. To get more space on the screen, you can select to shrink the
Function Wizard dialog.

When you select , the formula is inserted into the spreadsheet.

✍ Exercise: Work with Formulas
Ask your parents for the receipt of their last shopping trip, or
think of the things you need to buy when you go to the store
the next time. Rebuild the receipt in OpenOffice Calc. The
sum and the taxes should be computed using Calc formulas.

3.3.5 Create Charts

OpenOffice Calc also helps you with creating
charts. For this, you need the information in a
simple table.

Select the cells of the table.If you want you can
select the table including the labels of the rows
and columns.
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3.3 Work with Spreadsheets

Select Insert → Chart from the menu or from the toolbar.

The mouse pointer changes and you can draw a rectangle, that will include
the chart when you finish using the wizard. After releasing the mouse
pointer, a chart wizard appears.

Deselect these op-
tions if you have not
selected any labels.

Normally, the Range of cells is taken from your selection correctly and
you can select .

In the next dialog you can select the type of your chart.

Activate this option if
you want to see text
elements in the preview.

Depending on the kind of data, not all type of charts make sense for
charting all kinds of data.
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Lines Areas

Columns Bars

Pies XY Chart

Net Stock Chart

Very important in the dialog is also the option,
whether the data series are in Rows or Columns.

In the next dialog you can select a variant of the selected chart type. Here
you also can add grid lines.

Once again the chance to
select whether data series
are in Rows or Columns.

In the last dialog you can enter a chart title and axis titles.
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3.3 Work with Spreadsheets

Select Legend to include
a legend into your chart.

Select to create the chart.

You can move and resize the chart after you select it. It is also possible
to change the colors if you double-click the chart.

✍ Exercise: Create Charts
Look in your school reports for your grades in mathematics
over the last few years.

Create a small spreadsheet with a chart that shows your
progress in mathematics.
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3.3.6 Print Spreadsheets

Understand the Basic Printing Procedure

Printing a spreadsheet is very similar to printing a text document. Select
File → Print. A Print dialog appears.

In the Print dialog, you can choose a Printer, specify the Print range (how
much of the document you want to be printed), and select the Number of
copies to be printed. When you click , you actually send the
print job to the printer.

Adjust the Page Settings

By adjusting the page settings, you can control exactly how your spread-
sheet is printed. To adjust page settings, select Format → Page. The
Page Style dialog appears.
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3.3 Work with Spreadsheets

The most important options affecting the printing of a spreadsheet can
be found on the Page tab of the dialog. Here you can configure the paper
format, the paper margins, and some common layout settings.

Other printing options can be found on the Sheet tab.
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The dialog offers options in three different groups:

Page order. Here you can specify how the spreadsheet is printed when
it does not fit on one page. The Top to bottom, then right option
prints vertically from the top to the bottom. The Left to right,
then down option prints first from left to right. The graphics on the
dialog help illustrate the settings.

Print. Here you can control which elements of the spreadsheet should be
printed in addition to the content of the sheet.

Scale. This option lets you control how the spreadsheet is scaled to fit
on the paper. You can either adjust a percentage value to reduce or
enlarge the printout, or you can specify the number of pages which
should be used for the printout.

3.3.7 Create Serial Letters

Using serial letters you can send one letter to
different people. The names and addresses are
inserted automatically.

Before you can create a serial letter in OpenOffice Writer you need a
source for the input data. This could be a Calc table or a database, for
example.
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3.3 Work with Spreadsheets

To show how to create a serial letter, we use a simple table that only
contains a few names.

When finished with your table you can save it and close OpenOffice Calc.

Start OpenOffice Writer and write your letter. Sometimes you will come
to the position where the names should be set in. You have to insert a
field. Select Insert → Fields Other and activate the Database tab.

To add your Calc table to the available databases, select .
Now you can select the Calc file you created before.

The file should be added to the Database selection list.

Select Mail merge fields in the Type list and open the tree of your file
in the Database selection list.
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3 Use Open Source Tools

Select Mail merge

fields.

The column heads should be shown in the tree like in the previous screen
shot.

Now you can select the field, you want to insert. Select .

The fields are shown in
the letter with brackets and
grey background.

If you select File → Print a message appears.

If you select the Mail Merge dialog appears.
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3.3 Work with Spreadsheets

Select which records
you want to print.

Select to print the serial letter for the selected records.

✍ Exercise: Create Serial Letters
Write an invitation to your next birthday party. This invita-
tion should be a serial letter to ten of your friends. Include
the following information in your serial letter:

Z Last Name

Z First Name

Z Street

Z City

Z ZIP Code
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3.4 Create Formulas using Math

OpenOffice Math is an easy tool to help you write formulas. You can
start the tool in two ways:

❶ Select Insert → Object → Formula from the menu of an OpenOf-
fice component.

In this frame you
create the formula.

❷ By searching in the main menu. (OpenOffice Math does not have
an icon in the Application Browser by default.)

In this frame you see a
preview of the formula.
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3.4 Create Formulas using Math

The Selection window is devided into two parts.

Z The top part shows eight icons of mathematical categories:

– Unary/Binary operators

– Relations

– Set operators

– Functions

– Operators

– Attributes

– Others

– Brackets

– Formats

Z The items of a category are shown in the bottom part of the window.

Selecting one of the items inserts a symbol or a command in the lower
frame. This symbol or command represents the selected operation.

E.g., from the category, inserts <?> over <?>

Replace the <?> with numbers, variable names, other operators or expres-
sions.

To refresh the preview manually click the
frame once with your mouse.

If you know the symbols or commands, you
can enter them directly into the lower frame.
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To group parts of the formula, use curly brackets {...}.
For example, the formula a + b over 2 creates:

To get the formula

you have to group {a + b}. The text of the formula
should look like this: {a + b} over 2

If you need greek symbols, select Tools → Catalog.

You can save a formula as an .odf file and include it in other OpenOffice
documents.

✍ Exercise: Create Formulas using Math
Build the following formulas:

Z

Z

Z

208 c©2007 Novell Inc. Copying or distributing all or part of this manual
is protected by a Creative Commons

Attribution-NonCommercial-ShareAlike 2.5 license.



3.5 Work with Presentations

3.5 Work with Presentations

You can use a presentation program to prepare electronic presentations.
These presentations can be displayed on a computer screen or projected
on a large screen using a video projector. You can also print your presen-
tations on paper or transparencies.

OpenOffice Impress is similar to Microsoft
PowerPoint, another commonly used presenta-
tion program. If you have worked with Power-
Point before, you can use a lot of your Power-
Point skills and knowledge when working with
OpenOffice Impress.

Presentation files in OpenOffice Impress are saved as .odp files. Impress
can also import and export PowerPoint files.

To save a presentation file, select File → Save. You should save your
presentation files frequently so you can avoid losing too much data if the
program crashes.

3.5.1 Start OpenOffice Impress

To start OpenOffice Impress, select OpenOffice.org Impress from the
Office group in the Application Browser. After a moment, the Presen-
tation Wizard dialog appears.
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3 Use Open Source Tools

You can choose from the following Type options:

Z Empty presentation. Creates a new blank presentation.

Z From template. Creates a new presentation based on a template.
(OpenOffice Impress comes with two sample templates.)

Z Open existing presentation. Lets you open an existing presen-
tation from a file.

To begin creating a new presentation, select the Empty presentation

option or the From template option. Then select .

Now you can configure a slide background.

Select your output
medium here.

There are some predefined backgrounds available in the upper section,
but you will learn how to create your own design later.

In the next dialog you can select the transition effects and other presen-
tation options.
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3.5 Work with Presentations

When you have reached the last step, select to create your new
presentation.

To work on an existing presentation, select Open existing

presentation at the first Presentation Wizzard dialog and then
. You can choose an existing presentation file from the dialog

that appears.

3.5.2 Insert and Edit Slide Content

Choose a Slide Layout

When you select in the Impress screen appears.

The screen is divided into three parts:

❶ List of slide previews

❷ Current slide

❸ Task frame
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3 Use Open Source Tools

In the task frame there is a menu Layouts. From there you select a slide
layout for the slide you are creating. The layout of the slide you select
determines how text and images will be placed on your slide. To use a
particular slide layout, select the layout icon. The layout is inserted into
the current slide immediately.

This layout was
selected.
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3.5 Work with Presentations

Each time you want to add a slide to the presentation you are currently

working on, select Insert → Slide or from the toolbar.

Insert and Edit Text

To insert text on a presentation slide, select a text frame—inserted by
the layout—with the mouse. The frame is highlighted and you can start
typing text in this frame.

To finish your input, click somewhere outside the frame.

To edit an existing text frame, move the pointer over the text frame.
When the pointer changes its shape into a cursor, you can select the text
frame and edit its content. When you move the pointer over the frame
border, you can select the frame itself instead of its content.

When the frame is selected, you can move the frame to a different position
on the page. You can also change the size of the frame by selecting and
moving one of the green dots in the frame border.

Format Text

You can format text in text frames just as you would format text in
OpenOffice Writer. Use the pointer to turn on the edit mode in the frame
and mark the text that you want to format. Then use the Text toolbar
to change font, font size, alignment, and other text formatting features.
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You can also format the text frame. For example, you can format the
border around the text frame or the background color of the frame. To
format a text frame, you first have to select the frame. Select just the
frame border; do not turn on the edit mode. Then, using the Frame
toolbar, you can (from left to right) adjust the border thickness, border
color, and background color.

Insert Graphics

To add a graphic to a slide in your presentation, select a layout including
a graphic. Double-click the graphic frame. Alternatively you can select
Insert → Picture → From File from the Impress menu or from the
bottom toolbar.

Then select a graphic file from your hard disk. After the graphic has been
inserted, you can format it just as you would format a graphic in a text
document.

Insert Drawings

OpenOffice Impress offers drawing tools which you can use to add basic
elements to the slides. You can access these tools in the toolbar on the
bottom of the program window.

The drawing tools allow you to create different
kinds of drawing elements such as rectangles,
ellipses, 3D objects, and lines. Most tools come
with a set of variations. To see a tool’s varia-
tions, select the tool and hold down the mouse
until a small selection window pops up. You
can select a tool variation from this window.
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3.5 Work with Presentations

After you have selected a drawing tool, move the cursor to the position on
the slide where you want to insert the drawing. Then press the left mouse
button. If you move the cursor while still holding down the mouse button,
you can determine the size of the drawing element. When it reaches the
correct size, you can release the mouse button.

✍ Exercise: Insert and Edit Slide Content
Create a presentation about OpenOffice Calc with five slides.

3.5.3 Manage Slides

Rename and Delete Slides

Each slide has a name which is displayed at the bottom of the preview.

By default, the slides are numbered Slide 1,
Slide 2, Slide 3, and so on.

These default names are not very helpful if you have a large presentation
and you are trying to locate a particular slide.

Name of an
empty slide.
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You can give a slide a more descriptive name by right-clicking its entry in
the tab bar and selecting Rename Slide in the pop-up menu that appears.

Type a new name in the Rename Slide dialog that appears and select
.

To remove a slide from your presentation, right-click the slide’s preview
and select Delete Slide from the pop-up menu that appears.

Change Slide View

The view you have been working is called the Normal view. In this view,
you see a single slide that can be edited.

OpenOffice Impress also provides some other views which can be accessed
by the tabs in the frame of the current slide.

Select a view.

216 c©2007 Novell Inc. Copying or distributing all or part of this manual
is protected by a Creative Commons

Attribution-NonCommercial-ShareAlike 2.5 license.



3.5 Work with Presentations

Normal Change the content and layout of a slide

Outline Create an outline for your presentation

Notes Add notes to each slide

Handout Create a handout with smaller sized slides

Slide Sorter Change the order of the slides using drag and drop

Change the Slide Background

To change the background of a slide, select Format → Page and activate
the Background tab.

Under Fill, you can select

Z None

Z Color

Z Gradient

Z Hatching

Z Bitmap

The dialog changes depend-
ing on your choice. You can
scroll through the list of col-
ors, gradients, hatchings or
images.

c©2007 Novell Inc. Copying or distributing all or part of this manual
is protected by a Creative Commons

Attribution-NonCommercial-ShareAlike 2.5 license.

217



3 Use Open Source Tools

When you select to confirm your selections, the Page Settings
prompt appears, asking you if you want to apply the background settings
to all of the slides in the presentation.

If you select , your changes to the
slide background will be applied to all of
the slides in the presentation.

Use the Master Page

In addition to changing the background color of all slides in a presentation,
you can also configure other presentation-wide settings. For example, you
can add a logo or set up common font sizes.

Switch to the Master Page by selecting View→ Master→ Slide Master.

Instead of real slide content,
the Master Page displays
only a schematic view of
a slide. Everything you
change in the Master Page
is automatically applied to
all slides in the presenta-
tion.

If you insert a graphic into the Master Page slide, for example, the graphic
will be visible on all slides in the presentation. Likewise, if you adjust the
font size for titles in the Master Page, the font size of titles on all slides
will be adjusted.

To switch back to normal mode, which allows you to edit each slide indi-
vidually, select .
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3.5 Work with Presentations

The available Master
Pages are shown in the
task frame.

Change Slide Transitions

To beautify your presentation, you can use effect transitions between the
slides.

The available transitions.
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The frame contains three sections:

Z Apply to selected slides. Choose one of the available transi-
tions from the list.

Z Modify transitions. Select the speed for the transition. It is also
possible to play sounds during the transition.

Z Advance slide. If you want to play your presentation automati-
cally you can activate it here.

✍ Exercise: Manage Slides
Change the background and transitions of your Calc presen-
tation.

3.5.4 Give a Presentation

Start the Presentation Mode

After you have created all of the slides for your presentation, you can start
the presentation mode by selecting Slide Show → Slide Show. You can
also press the F5 key or select to start the presentation. In
presentation mode, the slides are displayed in full screen without any
window borders.

To leave the presentation mode, press Esc .

Navigate in Presentation Mode

When you are in the presentation mode, you can switch to the next
slide in the presentation by clicking the left mouse button or by pressing
Right arrow .

To go back one slide in your presentation, you can click the right mouse
button or press Left arrow .
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3.6 Draw Images Using Draw

Print Presentations

Although presentations are designed to be viewed on a screen or presented
with a video projector, sometimes you may want to print them on paper.
For example, you might want to use a printed version of the presentation
as a handout for your audience.

To print your presentation, select File → Print, choose a printer, and
confirm the print job by clicking .

To print the presentation outline, the slides with your notes or the hand-
out, activate the corresponding tab and select File → Print then.

✍ Exercise: Give a Presentation
Show your presentation to your classmates. Print a handout.

3.6 Draw Images Using Draw

3.6.1 Basics of Computer Graphics

There are two types of computer graphics:

❶ Bitmaps

❷ Vector images

Bitmaps are built from a matrix. Each field in the matrix is called a point

or dot.

The finer the matrix the higher the quality of the image. The number of
points per inch is called resolution.

Each point has a defined color.
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Low resolution Higher resolution Highest resolution

In vector images everything is described in geometrical shapes, like lines,
curves. A line can be described by the coordinates of the beginning and
the coordinates of the end. It has a certain thickness, and can be dotted
or not.

Enlargement of a vector image means only that the com-
puter has to compute the new coordinates. The quality
of the image is not effected.

✍ Exercise: Basics of Computer Graphics
Think about the advantages and disadvantages of bitmaps and
vector images. Complete the following table.

Bitmap Vector Image

File size of large
images
Quality after
zooming
Used computing
time for zooming
Suited for photo
manipulation?

yes

Suited for techni-
cal graphs?
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3.6 Draw Images Using Draw

3.6.2 Start OpenOffice Draw

OpenOffice Draw can be used to create vector images.

You can start OpenOffice Draw by selecting File → New → Drawing

from the menu of another OpenOffice component or be selecting
OpenOffice.org Draw from the Images group in the Application
Browser.

3.6.3 Create a Drawing

You can launch OpenOffice.org Draw from the Programs menu using
Office→ Drawing or from any running OpenOffice.org application using
File → New → Drawing.

In the left frame you see a preview of the pages. The current page is
shown in the right frame.
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OpenOffice Draw offers drawing tools which you can use to add basic
elements. You can access these tools in the toolbar on the bottom of the
program window.

The drawing tools allow you to create different kinds of drawing elements
such as rectangles, ellipses, 3D objects, and lines. Some tools come with a
set of variations. To see a tool’s variations, select the tool and hold down
the mouse until a small selection window pops up. You can select a tool
variation from this window.

Select an existing object.

If you select an object once, small green dots at the corners indicate
that the object is selected. You can resize the object if you click
one of these squares, keep the mouse button pressed and move the
mouse.

Resize the rectangle here.

Draw a line

Draw a line that ends with an arrow

Draw a rectangle

Draw an ellipse

Write text

Menu that contains eight variants of curves. You can finish a curve
by double-click
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3.6 Draw Images Using Draw

Menu that contains twelve variants of connectors. Connectors are
lines between objects. If the object is moved, the line stays con-
nected.

Points for connection.

Menu that contains ten variants of lines and arrows.

Menu that contains a lot of simple geometrical figures.

Menu that contains some symbol shapes.

Menu that contains a lot of shapes for block arrows.

Menu that contains shapes for flow charts.

Menu that contains shapes for callout balloons.

Menu that contains twelve shapes for stars.

Some tools allow you to manipulate the points of the shape later,
e.g. rectangle. Select this tool to switch to point manipulation.

Manage glue points. A glue point is a custom connection point
where you can attach a connector line.

Create text with graphical effects.

You can select a style from the font gallery.
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Include a picture from file.

Include an image from the OpenOffice gallery.

Menu that includes eight effects, like rotate, mirror and 3D rotation.

Select the alignment for the selected object from this menu.

A new object always lays on the top of the older objects. You can
change the order of the objects using this menu.

Use extrusion to create a 3D object out of a 2D object.

✍ Exercise: Create a Drawing
For a lot of drawing tools Shift and Alt can be used as
modifiers. Write down the functions of Shift and Alt for
the following tools.

Tool Shift Alt
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3.6 Draw Images Using Draw

./.

3.6.4 Specify Lines and Fills

To specify the poperties of a figure, there is the line and fill toolbar at
the top of the OpenOffice window.

If there is an object selected, you can change the line and the fill for the
selected object here.

If there is no object selected, the properties are valid for all subsequently
created objects.

The items are described briefly here.
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Open the Stylist. As in OpenOffice Writer,
the Stylist in OpenOffice Draw allows to define
styles for fonts.

Open a dialog to configure lines.

Select the ends of arrow from this menu.

Select the style (e.g., dotted, dashed, solid) of a
line or border from this menu.
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3.6 Draw Images Using Draw

Specify the width of lines and borders.

Select the color of lines and borders.

Open a dialog to configure the fill of areas.

Select the style of the fill (e.g.,solid color, gradi-
ent) from this menu.

Select the color of the fill.

Add a shadow to the selected object.

✍ Exercise: Specify Lines and Fills
Draw a woman and a man.

3.6.5 Group Objects

You can select objects with a mouse-click. If you want to select more
than one object, keep Shift pressed, when selecting the second object.
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Alternatively you can click on the background, keep the left mouse-button
pressed and drag the mouse. A rectangle appears on the screen. If you
release the mouse-button all objects inside the rectangle are selected.

You can see how many objects are selected
in the status bar at the bottom of the
OpenOffice window.

If you finish a part of your image and you do not want to change the
arrangement anymore, it is a good idea to group the objects. Then you
can handle the group as one single object.

To group the selected objects, select Modify → Group. To ungroup a
selected group of objects, select Modify → Ungroup.

✍ Exercise: Group Objects
Create the following groups for your woman and man figures:

Z Face

Z Arms

Z Legs

3.6.6 Use Grid

A grid is very helpful to align objects. You can configure a grid by select-
ing Tools → Options.
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3.6 Draw Images Using Draw

Select the options for
OpenOffice.org Draw.

Open the menu for OpenOffice Draw and select Grid.

Select Grid.

There are five important options:

❶ Select Snap to grid, if you want to align your objects to the grid.
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❷ Select Visible grid, if you want to see the grid on the screen.

❸ Specify the horizonal resolution of the grid at Horizontal.

❹ Specify the vertical resolution of the grid at Vertical.

❺ If you want to use snap lines to align your objects, activate To snap

lines.

A horizontal snap line can be created by
clicking on the ruler at the top. Keep the
mouse button pressed and move the mouse
pointer down.

A vertical snap line can be created by
clicking on the ruler at the left. Keep the
mouse button pressed and move the mouse
pointer to the right.

A snap line is not printed.

To remove a snap line move it back to the ruler.

✍ Exercise: Draw Images using Draw
Draw a landscape with mountains, trees, and clouds. Copy
your woman and man figures into your landscape.

3.7 Use Gaim

IRC (Internet Relay Chat) is one of the first standards from the begining
of the internet. Communication via IRC is called “chatting.”

Instant messaging (IM) is a newer development of chatting, and has be-
come more popular than IRC. The advantages of instant messaging in
contrast to IRC are:
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3.7 Use Gaim

Z You can create a list of your contacts

Z You can see who of your contacts is online or ready for chatting

Z You can send files

There are a lot of instant messaging standards (proto-
cols) available. The most common are:

Z AIM/ICQ (from AOL/Mirabilis)

Z Yahoo

Z Groupwise (from Novell)

Z MSN (from Microsoft)

The Linux application Gaim supports all these protocols and some more.

i You can get a free instant messaging account for yourself from any
of these websites:

Z http://www.icq.com

Z http://www.yahoo.com

3.7.1 Create an Account

When you select Gaim from the Communicate group
in the Application Browser, three windows appear
on the screen. One window is labeled “Add Ac-
count.”
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Select the protocol
you own an account.

Depending on the selected protocol the dialog changes because each pro-
tocol requires different parameters. But there are some parameters you
need to enter for each protocol:

Screen Name – Your login for the instant messaging provider.

Password – Your password.

Alias – An alias for your account which is visible for your
communication partners.

Remember password – If this option is not activated you will always need
to authenticate when you connect to your instant
messaging provider.

Auto-login – If this option is selected the connection to your
instant messaging provider is built automatically
after starting Gaim.

When you have configured your account, select and your ac-
count is added to the Accounts window.
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Activate Online to estab-
lish the connection to the
instant messaging server.

3.7.2 GNOME Password Keyring

You know the problem of keeping dozens of passwords in mind:

Z for mail access

Z for FTP space

Z for instant messaging

GNOME provides a tool that
stores all the (encrypted) pass-
words and provides them if
necessary. The advantage is, you
only have to keep the password for
accessing the keyring in mind.

When the keyring is called the first
time, you have to enter a password
for it twice.

✍ Exercise: Create an Account
Create an ICQ account at https://www.icq.com/register

for yourself and configure Gaim.
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3.7.3 Manage Buddies

After you have configured your own account and have established a con-
nection to your instant messaging server, you now need to configure the
accounts of your buddies.

Do this inside the Buddy List window.

Add a Buddy

Select Buddies → Add Buddy to add a new buddy.

Enter the screenname of your buddy. You also can enter an alias name
and a group this buddy belongs to.
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If you have more than one ac-
count, you can select the one you
want to use for this buddy.

✍ Exercise: Manage Buddies
Add three of your class mates as your buddies to Gaim.

Your buddy gets a notification that you added him to your buddy list,
and he can add your account by selecting .

After entering an alias name, your buddy is added to the Buddy List.

If you want to remove a buddy from your
Buddy List. Right-click the entry and select
Remove. You are asked for confirmation.
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Add a Group

If you have a lot of buddies it is good to build groups to organize them.
You can add a group by selecting Buddies → Add Group.

You are asked to enter a group name.

Select to add the group to the Buddy List.

You can use drag and drop to put a buddy into a group.

3.7.4 Chat

Communicate with Buddies

Double-click the buddy you want to chat with in the Buddy List.

Enter your text here.
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Depending on you IM protocol, the icons between the two text boxes can
be used to format your text. The meanings are:

– Bold font

– Italic font

– Underline

– Enlage font

– Reduce font size

– Select font

– Change text color

– Change background color

– Insert link

– Insert image

– Insert smiley

If you select the Send icon, your message is sent. Alternatively you can
press Enter .

To create a line break in your mes-
sage, press Shift + Enter .

Block a User

If you are annoyed by another instant message user, you can block
their account by selecting the Block icon in the conversation di-
alog.

You are asked for confirmation.

To remove this block, select Tools → Privacy.
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Select a rule from
this menu.

There are five rules available:

❶ Allow all users to contact me

❷ Allow only the users on my buddy list

❸ Allow only the users below

❹ Block all users

❺ Block the users below

✍ Exercise: Block a User
Block one of your users and test the effects of a block.

Change your Status

When you go online with Gaim, the people who added you as their buddy
can see that you are online and ready to chat.
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If you want to stay online but not be
disturbed, you can leave a message for
your buddies. Select the Away button in
the Buddy List window. A menu pops up
showing a list of predefined messages.

If you want to create your own message,
select New Away Message from the menu.

Alternatively you can select Away from the Tools menu.

A message looks
like this.

✍ Exercise: Chat
Discuss via Gaim with one of your classmates about “the
benifits of using instant messaging at school.”

3.7.5 Customize Gaim

You can customize Gaim by selecting Tools → Preferences.
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When you close all Gaim windows there will be still an
icon in the bottom panel and you are visible for others.

To exit Gaim, rightclick this icon and select Quit.
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3.8 Use the Collaboration Software Evolution

3.8 Use the Collaboration Software Evolution

Collaboration software is very important in companies today. It allows
you to manage emails, contacts and appointments. You can share it
with your colleages. Using collaboration software at school can make it a
powerful tool to manage your work.

There are a several collaboration software packages available for Linux,
such as:

Z Evolution

Z Novell Groupwise

Z OpenExchange

Here we will talk about the open source project Evolution. It was de-
veloped by Ximian, before Novell bought their company and released
Evolution as an open source product.

3.8.1 Configure Evolution

You can start Evolution by selecting Evolution in the main menu.

Select Evolution.
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The first time you start Evolution, a wizard runs to help you configure
the program.

Select to begin the configuration.

In the Identity screen, type your full name and email address.
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3.8 Use the Collaboration Software Evolution

Under Optional Information, you can enter the name of your school
and another email address to which replies to emails will be delivered.
Select to go to the next screen.

Next, you need to provide information
about your incoming mail server.

You can get the internet mail settings from
your school’s network administrator.

Choose the appropriate set-
tings for your account from the
Server Type pull-down menu.
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Possible server types are:

Z Hula. Choose this option if you want to access a Hula server.

i You can find more information about the open source group-
ware Hula find at http://www.hula-project.org.

Z IMAP. Choose this option if you want to access an IMAP mail server.

Z Microsoft Exchange. Choose this option if you want to access a
Microsoft Exchange server.

Z Novell GroupWise. Choose this option if you want to access a
GroupWise server.

Z POP. Choose this option if you want to access a POP mail server.

Z USENET news. Choose this option if you want to access a news
server.

Z Local delivery. Choose this option if your workstation or server
is working as a mail server or if it is not connected to a network.

Z MH-format mail directories. Choose this option if your email
messages are already delivered to a spool using the MH format.

Z Maildir-format mail directories. Choose this option if your
email messages are already delivered to a mounted mail directory.

Z Standard Unix mbox spool or directory. Choose this option if
your email messages are already delivered to spool using the mbox
format.

Z None. Choose this option if you do not want to receive email.

You might need more information for the Configuration part of the dialog.
For instance, you might have to specify the host of your email, your
username on that host, and a password. You might have to select a
mail directory where new email messages can be stored. You can get
these settings from your network administrator or your internet service
provider.

In most cases, you have to choose
between IMAP and POP.
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3.8 Use the Collaboration Software Evolution

Select to continue configuring incoming mail.

The options in the next dialog will vary slightly, depending on the server
type that will be receiving mail.

In most cases, you have to specify how often your mailbox will be checked
for new mail.

Select to go to the next dialog.
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Now decide which type of transport you want to use to send email:

SMTP – Configure the details of your mail servers manually.

Sendmail – Apply the settings if your workstation or server already acts
as a mail server. Choose this option if your machine is not
connected to a network.

In most cases you will select SMTP. If you
are not sure which option to select, ask your
school’s network administrator.
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3.8 Use the Collaboration Software Evolution

You can enter the server settings for sending email by

Z Entering the host name of the server Host.

Z If the server requires authentication, specifing

➪ Type. The type of authentication.

➪ Username. Your login name.

Select to continue.

You can enter a name for your configuration in this dialog. Naming your
configuration is useful, particularly if you have to manage multiple mail
accounts (one for private mail and one for business mail, for example).

Select to go to the last configuration dialog.
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Specify the time zone in which you will receive mail.

You can select the time zone
by clicking the map or by
choosing a time zone from the
Selection menu.

Select . You should receive a confirmation that the configuration
was successful. Now you can start Evolution by selecting .

✍ Exercise: Configure Evolution
Configure Evolution so that it allows you to receive and send
email from your school email account.

3.8.2 Read Email Messages

When you start Evolution, the email dialog appears.
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3.8 Use the Collaboration Software Evolution

Start the modules of Evolution
with these five buttons.

You can see the list of available mail folders in the left frame above the
module buttons.

If you select a folder, all mail inside this folder is listed on the right. In
addition, you can see who the email is from, the subject of the email, and
the date the email was sent.

The icons at the beginning of each email entry indicate the following:

– Unopened envelope: If the envelope is closed, the email is new and
unread.

– Attachment: The email includes an attachment.

– Exclamation mark: The email includes important information.

When you select an email message in the list of email messages, it is
displayed below the list.

✍ Exercise: Read Email Messages
Read the welcome mail from the Evolution team.
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3.8.3 Compose and Send Email Messages

After you have configured Evolution, you can begin writing and sending
email messages. To write a new message, select in the Evolution
toolbar.

The Compose Message window appears.

Type the recipient’s email address in the To field, and type a title
in the Subject field. After you type your message, select Send to
send the message.

If you want to send a carbon copy of your message to another recipient,
select View → Cc Field or View → Bcc Field. (By default, Evolution
does not show text boxes for carbon copy (Cc) and blind carbon copy
(Bcc).)

Email messages are created in plain text by default. Formatting buttons
are visible, but you can only use them if you send mail in HTML format.
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3.8 Use the Collaboration Software Evolution

To activate the HTML format, select Format → HTML.

You can write email messages to a user of
your local machine by using the email address
login@localhost. You do not need to be
connected to a network.

3.8.4 Reply to a Message

You received an email from a friend and now you want to send him an
answer. Maybe you want to refer to parts of your friend’s email in your
response.

To reply to a message, select the message in the list of email
messages and select Reply.

The original message appears as quoted text for editing. The sender of
the original message is automatically set as the recipient. The subject of
the original message is also copied.

If the original email was sent to more than one person and
you want to reply to everyone that received it, select Reply
to All.

Sometimes you will receive messages that you want to send
to another person. If you want to forward an email to a
friend or classmate, select forward.

The original email will be attached to the email message automatically.
Address the email message as usual. You can send the forwarded email
with or without including your own message in the body.
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3.8.5 Handle Attachments

Receiving Attachments

When you receive an email with an attachment, it will be marked with a
small paperclip icon ( ) in the list of email messages.

The attachment is also marked with icon at the top and at the bottom of
the message body.

The kind of icon that appears at the end of the body depends on the
attachment’s file type. An image is identified by a thumbnail icon of the
image.

When you click the icon, Evolution displays the content of the attachment
(if possible).

If you select the triangle button next to the attachment icon, a pop-up
menu appears asking whether the attachment should be opened with a
specific application or saved as a file.

Sending Attachments

You can attach a file to your email message before you send it.
To add an attachment, select Attach in the toolbar.

A standard file selection dialog appears. You can navigate through the
directory structure and select the file you want to attach to the email
message. Then select .
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A new frame at the bottom of the Compose window
indicates which files are attached to the email.

Each attached file is identified with an icon. Image file
icons are usually thumbnails of the images themselves.

✍ Exercise: Handle Attachments
In the directory /opt/gnome/share/pixmaps/backgrounds/

there are a lot of wallpapers. Send one of these image files to
a classmate.

If you receive a email with an attached wallpaper, you could
save it into your home directory.

3.8.6 Manage Email Folders

If you are receiving many email messages a day, you probably need more
than one folder in which to store your messages, and you probably need
a system to organize them.

To create a new mail folder, select File → New → Mail Folder or select
Mail Folder from the pull-down menu.

A Create folder dialog opens.
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Type the name of the new folder
in the Folder name field.

Under Specify where to create the folder, indicate where you want
the folder to be located.

If you select On This Computer, the new folder will be
created at the same level as the Inbox folder.

If you select one of the other folders, such as Drafts, the
new folder will be created as a subfolder of the selected
folder.

✍ Exercise: Manage Email Folders
Create a new folder “Classmates” inside the Inbox folder.

3.8.7 Filter Incoming Emails

Basics of Filtering Email Messages

Suppose you are receiving several email messages every day. You already
created several mail folders, but manually sorting the messages into these
folders each day is difficult and time-consuming.

You can filter your incoming email messages automatically. Message fil-
tering has the following advantages:
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Z You can easily separate important and unimportant email messages

Z You do not need to sort your email messages manually

Z You can eliminate some of the spam and junk email automatically

You can filter your email by setting up filter rules. A filter rule contains
two parts:

❶ The condition or criterion (the “if” part) describes what should be
filtered out.

❷ The action (the “then” part) describes what should happen to the
email message if it meets the condition.

For example: If the sender is Tux, then move the mail
into folder XYZ.

Manage Filter Rules

To create a new filter rule, select Edit → Message Filters.

You can select an item from Message →
Create Rule to shorten the process of creat-
ing filter rules, but we want to describe the full
filter creation process here.

The Manage Filters dialog appears. This dialog allows you to manage
your filter rules.

c©2007 Novell Inc. Copying or distributing all or part of this manual
is protected by a Creative Commons

Attribution-NonCommercial-ShareAlike 2.5 license.

257



3 Use Open Source Tools

Here you can specify whether you
want to manage the filters for incom-
ing or outgoing email messages.

The seven buttons on the right side of the Filters dialog let you do the
following:

– Create a new filter rule

– Edit the selected filter

– Remove the selected filter

– Move the selected filter to the top of the list

– Move the position of the selected filter up one item

– Move the position of the selected filter down one item

– Move the selected filter to the bottom of the list

Each email message is filtered starting with the filter rule at the top. If the
first filter condition matches, that filter is used. If the first filter condition
doesn’t match, the next filter is checked, and so on down the list until a
match is found. When a filter condition matches, the associated action
will be taken, and the search for a filter will end.

258 c©2007 Novell Inc. Copying or distributing all or part of this manual
is protected by a Creative Commons

Attribution-NonCommercial-ShareAlike 2.5 license.



3.8 Use the Collaboration Software Evolution

Create a New Filter Rule

To create a new filter rule, select on the Filters dialog. The Add
Rule dialog appears.

In the Rule name field, type a name for the rule you want to create.

In the window area labeled Find items that meet the following

criteria, specify one or more filter conditions.

In the window area labeled Then, specify one or more filter actions.

Create a Filter Condition

To create a filter condition, you need to understand the following infor-
mation.

One filter can check each email message for a specified condition. Each
condition is represented by one line in the If area on the Add Rule dialog.
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By default, a filter has only one line, so you can only specify one filter
condition. If you want to create a second line for a second filter condition,

select .

If you list more than one condition in your filter, the Find items pull-
down menu becomes complicated. You must specify whether the action
will be executed

Z If all criteria are met or

Z If any criteria are met

Each condition is made of three pieces of information:

❶ What part of the email contains the information that
is being considered? (for example, the sender, the sub-
ject, the body, the size of the mail, and so on). You
must select an item from the Sender menu (explained
below).

❷ What must this part do or be? (For example, it must
be equal to something, or not equal to something, or
it must contain something.) You must select an option
from the contains menu (described below).

❸ What is the criterion (the something)? You must define
the something (explained below).

When you create a filter condition in the Filters dialog, you must first
select an item from the Sender pull-down menu. You can select one of
the following options:

Z Sender

Z Recipients
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Z Subject

Z Message Body

Z Date sent

Z Date received

Z Size (kB) (of the email message)

Z Attachments (did the email have an attachment)

The contains pull-down menu lets you select the criteria which the item
you selected from the Sender menu should meet. The menu includes the
following options:

Z contains something

Z is equal to something

Z starts with something

Z ends with something

Z sounds like something

You must define the ”something” (criterion) in the empty text box next
to the contains menu. The something could be an email address, a date,
a file size, and so on, depending on what you selected in the Sender

pull-down menu.

If you want to delete a condition, you can select at the end of the
condition’s line.

Create a Filter Action

After you have defined the filter condition, you can start defining the filter
action (the Then part of the filter).
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If you want more than one action, you can add a new action by selecting

under Then.

Each action is written on one line and consists of one or two items.

From the Move to Folder pull-down menu, you can specify what should
be done with an email that meets the filter condition. For example, you
can choose to:

Z Move the email message into a special folder

Z Copy the email message into a special folder

Z Change the color of the email title in the list of email messages

Z Assign the email message a special status

Z Have the computer beep or play a sound

Z Start a special program

Some of these actions require additional information (the name of the
folder the email will be moved or copied to, or the name of the sound
to be played, for example). You can enter this information in the click

here to select a folder pull-down menu.

If you want to delete an action line, select at the end of the line.

✍ Exercise: Manage Filter Rules
Create a filter rule that moves mails
from your classmates into the email
folder “Classmates.”

3.8.8 Add an Address Book

Evolution provides a Contacts module that you can use to
manage your address books and contacts.
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You can start the Contacts module by clicking the Contacts button in the
bottom left corner of the Evolution dialog.

The Contacts dialog appears:

The content of the address book appears in the large frame on the right
side of the window.

To search for a particular contact, open the Name begins with pull-down
menu.

When selecting Name begins with you see a pull-down menu with the
following items:

Z Name begins with
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Z Email begins with

Z Category is

Z Any field contains

Z Advanced Search (for a more complex search)

Add a New Address Book

You might want to keep your contacts in different address books. For
example, you could store school contacts in one address book and personal
contacts in another address book.

To create a new address book, select File → New → Address Book or
select Address Book from the pull-down menu.

A Create folder dialog opens, which is similar to the dialog to create a
new mail folder (see page 256).

Under Type, indicate where you want the address book to be located.
Under Name you can enter a name for your new address book.

Then you can right-click the address book in the list and
select Delete from the pop-up menu.

✍ Exercise: Add an Address Book
Create a new address book “Classmates” inside the Contacts
folder.
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3.8.9 Add a Contact

To create a new contact, select . The Contact Editor dialog opens.

The Contact Editor dialog displays three tabs:

Z Contact. Includes the contact’s name, email telephone numbers
(work, home, mobile, and fax), and instant messaging accounts.

Z Personal Information. Includes the contact’s web addresses (if
any), job information, and birthday.

Z Mailing Address. Includes three addresses (home, work, other).

Most of the items on the Contact Editor tabs are self-explanatory. Some
of the special items are described below:

Z Full Name: To enter the name of your contact in more detail, select

.
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Z Categories: To separate a large number of contacts into categories,
select .

To add new category, select the Edit

Master Category List button in the
Category dialog.

Z Telephone: To list more than four telephone numbers for a contact,
select the triangle button ( ) next to the telephone label.

✍ Exercise: Add a Contact
Add ten of your classmates to your address book “Class-
mates.”

3.8.10 Add a Contact List

If you communicate with a particular group by mail regularly, you can
build a contact list for this group. With a contact list, you will no longer
need to select all addressees manually.

To create a new contact list, select New → Contact List. The Contact
List Editor appears.
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The items in the Contact List Editor dialog are described below:

Z List name. Assign the contact list a name.

Z Where. Address book where the contact list is stored.

Z Members. Add a member to the list by dragging a contact into
the text box, by using and or by typing in an email
address.

Z Hide addresses when sending mail to this list. Hide the
mail addresses in the mail header so contact list members cannot
see the addresses of other contact list members.

✍ Exercise: Add a Contact List
Create a contact list that includes your classmates.
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3.8.11 View the Calendar

Evolution contains a Calendar module that you can use to manage your
appointments.

To start the Calendars module, select the Calendars icon in the left frame
of the Evolution dialog.
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The Calendars dialog appears:

Select the calendars you want
to see by activating the
checkboxes in the left frame.

The content of the selected calendar appears in the center of the window.

You can use the small calendar on the right to quickly navigate through
the calendar.

The small frame in the lower right corner lists tasks that need to be
completed. Managing tasks is described later in this chapter.
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Evolution supports four views of the calendar:

Z Day: A single day is displayed in the main frame of the calendar
dialog.

Z Work Week: Five days (Monday to Friday) are displayed in the
main frame.

Z Week: Seven days (one week) are displayed in the main frame.

Z Month: One month is displayed in the main frame.

Z List: A list of all appointments with start and end.

Use the following icons to switch between the different views:

3.8.12 Navigate Through the Calendar

You can navigate through the calendar in several ways.

First, you can use the four navigation icons that appear in the icon bar
of the Calendar module:

– Jump to the previous day

– Jump to today

– Jump to the next day

– Select the day you want to jump to from a small calendar that is
displayed
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You can also navigate the Calendar using the small calendar on the right
side of the dialog:

To view a different month in the
small calendar, select the small dots
on either side of the month.

In the small calendar, select the day you want to view. The selected day
will be displayed in detail in the center of the Calendar dialog.

✍ Exercise: Navigate Through the Calendar
What day of the week are the following dates? Practice se-
lecting them.

Date Mon. Tue. Wed. Thu. Fri. Sat. Sun.

2nd Jan. 2009
14th Oct. 2007
30th Nov. 2004
8th Mar. 2008
6th Feb. 2030
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3.8.13 Add a New Calendar

You might want to store private appointments and school appointments
in separate calendars.

To create a calendar, select File → New → Calendar or select Calendar
from the pull-down menu.

A New Calendar dialog opens.

CalDAV is a protocol that al-
lows you to access calendar
files on other computers.

Under Type you can indicate where you want the calendar to be located.
Under Color, you can select a background color for the appointments
shown in the calendar view. The other information depends on the type
of the calendar.

Then you can right-click the calendar in the list and select Delete from
the pop-up menu.

✍ Exercise: Add a New Calendar
Create a new calendar “Classmates” inside the Calendar
folder.
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3.8.14 Create a New Appointment

To create an appoint-
ment, select in
the tool bar. The Ap-
pointment dialog ap-
pears.

The dialog has three important icons in the toolbar:

– Select this icon if you want to configure a reminder for the

appointment.

– Select this icon if your appointment is an all day event (e. g., a

birthday).

– Select this icon if the appointment recurs (described later).

The other items of the dialog are described here:

Z Calendar. Select a calender where the appointment is stored.

Z Summary. Type the name or a short summary of the appointment.

Z Location. Type the location of the appointment (optional).

Z Time. In the first textbox, specify the start date and in the second
text box the starting time. From the following menu, you can select
whether you want to specify the duration of the appointment (select
for) or the date and time when the appointment ends (until).

Z Description. Description of the appointment.

Z Show Attachment Bar. Like an email, you can add attachments to
an appointment by selecting the Attach icon in the toolbar.

Evolution can alert you before the appointment starts. Select the
Alarms icon in the toolbar.
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You can select the time of the alarm from the Alarm menu:

Z 1 hour before appointment

Z 1 day before appointment

Z 15 minutes before appointment

Z Customize

Z None

When selecting Customize, you can configure the time and kind of the
alarm in detail. To configure a new alarm, use .

A lot of appointments recur. You can easily configure recurrences
by selecting the Recurrence icon of the Appointment dialog.
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First, select this
checkbox.

In the line beginning with Every, specify the interval of the recurrences
(how often the appointment recurs). In the field next to Every, type a
number. Then select the interval from the day(s) pull-down menu. The
minimum is one day; the maximum is several years.

You also have to specify when the appointment stops recurring. This can
be a date or a number of recurrences. If you don’t know when the last
appointment will take place, select forever in the forever pull-down
menu.

You can enter exceptions for the recurrences in the Exceptions area. You
can add new exceptions by selecting or you can remove a selected
exception by selecting .
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The Preview at the bottom
of the Recurrence dialog high-
lights all appointment recur-
rences with a bold font.

✍ Exercise: Create a New Appointment
Create appointments for the birthdays of your classmates or
family members.

Create appointments for your Linux course.

3.8.15 Filter Appointments

Categories are useful if you have a large number of appointments and you
want to filter them. When creating an appointment you can select View
→ Categories.

A new line is added
to the dialog.

To view the list of available categories, select .
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The Calendars module lets you decide whether you want to display or hide
your appointments. To display the appointments, select the checkbox in
front of the calendar name. The appointments will be listed on the right
side. If you don’t want to see the appointments, deselect the checkbox.

If you manage a large number and variety of appointments, you might
want to filter them. Then you can view only those appointments that
you need to at a given time.

To filter appointments, you can use the menus above the right frame.

The left pull-down menu contains the following options:

Z Summary contains. Filter the appointments based on the summary
of the appointment.

Z Description contains. Filter the appointments by the descrip-
tion of the appointment.

Z Category is. Filter the appointments by category.

Z Location contains. Filter the appointments by the location of the
appointment.

Z Any field contains. Filter all configuration fields of the appoint-
ment.

After you have selected an option from the Category is menu, select an
option from the Any category menu. Your Category is menu choice
determines what options are available in the Any category menu.
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✍ Exercise: Filter Appointments
Use filters to see in the calendar only the appointments for
your Linux course.

3.8.16 Set Up a Meeting

You can use Evolution to set up a meeting with a classmate.

To set up a meeting, select
Meeting from the menu.
Alternatively, you can select
File → New → Meeting.

The standard Appointment dialog opens. However, now it has two more
items:

❶ a Free/Busy icon in the toolbar

❷ an area to manage the attendees of the meeting
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Because you are considered to be
the appointment organizer, your
email address should appear in the
Organizer field.

If you have more than one email account configured, you can select a
different address from the Organizer pull-down menu.

The main frame lists the people who have been invited to the meeting.

The table displays the following information. (You can change an item in
the table by clicking on it.)

Z Attendee. Name or email address of the attendee. You can type
in the information or you can select the attendee from your address
book by clicking the Contacts button.

Z Role. You can assign a special role to an attendee. The attendee
can be the chairman (select Chair), a Required Participant, an
Optional Participant or a Non-Participant. If you don’t know
the role of the attendee, select Unknown.

You can add attendees by selecting . Enter the mail address (or the
name in the address book) of the attendee and specify the attendee’s role.
Alternatively you can select and another dialog opens and allows
you to select the attendees.
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The new button Busy/Free in the appointment can be used
to determine when the people you invited to the meeting
have free time.

Each participant’s calendar
is displayed in a single line.

280 c©2007 Novell Inc. Copying or distributing all or part of this manual
is protected by a Creative Commons

Attribution-NonCommercial-ShareAlike 2.5 license.



3.8 Use the Collaboration Software Evolution

Possible meeting times are marked with a white column in the diagram.
You can use the and buttons to jump to an earlier or later times.

The options in the pull-down menu let you specify whether the
meeting time should match

Z All people and resources

Z All people and one resource

Z Required people

Z Required people and one resource

After you have configured the Free/Busy dialog, you can close
it. When you are done with the other meeting information,
select Send. The Evolution Query dialog appears:

When you receive an email invitation to a meeting, the email includes all
important information about the meeting.
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Using the buttons , , and indicate whether
you accept, tentatively accept, or decline the meeting invitation.

✍ Exercise: Set Up a Meeting
Create a meeting to preparate the next Linux course lesson.
Invite five of your classmates.

3.8.17 Create a New Task List

Evolution contains a Tasks module for managing your tasks.

To start this module, select the Tasks button in the left
frame of the Evolution dialog.

The Tasks dialog appears:

The available tasks are listed in the small frame above the module buttons
on the left side of the window. The large frame on the right shows the
individual tasks.

You might want to store private tasks and school tasks in separate task
lists. Create a new task list by doing one of the following
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Z Selecting File → New → Task List

Z Selecting Task List from the pull-down menu

Under Type, indicate where you want the task list to be located. Under
Name you can enter a name for your new task list. Under Color, you can
select a background color for the tasks shown in the tasks view.

To remove a task list, right-click the task list and select Delete from the
pop-up menu.

✍ Exercise: Create a New Task List
Create a new task list “Classmates” on
your computer.

3.8.18 Create a New Task

To create a new task, select in the tool bar.

The Task dialog appears:
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The dialog includes the following items:

Z Group. Name of the task list the task should be stored in.

Z Summary. Type the name or a short summary of the task.

Z Start date. You can use the Start Date menu to specify by when
(what date) the task needs to be started. The second menu on the
Start Date line lets you specify a start time.

Z Due date. You can use the Due Date menu to specify when (what
date) the task must be completed. The second menu on the Due
Date line lets you specify a completion time.

Z Description. Type a detailed description of the task.

When you have finished configuring the task, select Save to
create the new task.

✍ Exercise: Create a New Task
In the next two weeks you have to do the following tasks:

❶ Mow your lawn

❷ Prepare a presentation for your Latin course

❸ Buy a birthday present for your friend

❹ Phone your grandmother
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❺ Clean your room

Enter these tasks into Evolution.

Filter Tasks

Categories are useful if you have a large number of tasks and you want
to filter them. When creating a task you can select View → Categories.

A new line is added
to the dialog.

To view the list of available categories, select .

Evolution supports task lists. If you select the checkbox in front of the
task list name, the items of the task list are shown in the right frame. If
you deselect this checkbox, the items are not shown.

If you have to manage a large number and variety of tasks, you might
want to filter them. Then you can view only those tasks that you need to
at a given time.

To filter the tasks, you can use the menus above the right frame:
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The left pull-down menu contains the following options:

Z Summary contains. Filter the task based on the summary of the
task.

Z Description contains. Filter the task by the description of the
task.

Z Category is. Filter the task by category.

Z Any field contains. Filter all configuration fields of the task.

After you have selected an option from the left menu, select an option from
the Any Category menu. Your Category is menu choice determines
what options are available in the Any Category menu.

3.8.19 Manage Tasks

When you are working on a task, you may want to track its progress or
status.

Double-click the small notepad icon ( ) in front of the task name. The
Task dialog appears again.

To change or configure the status of a task, select the Status
Details icon in the toolbar.
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You can configure the following items:

Z Status. The status of the task. Here you can choose between the
following settings:

➪ Not Started

➪ In Progress

➪ Completed

➪ Cancelled

Z Percent complete. Select the percentage of completeness. This
value may influence the Status menu.

Z Priority. Specify the priority of a task (High, Normal, Low, or
Undefined).

Z Date completed. Type the date and time the task was completed.
If you select Completed from the Status menu, the current date
and time are inserted.

Z Web Page. To connect the task with a web page, type the URL
here.

Close the dialog to finish configuring the status of the task.

To delete a task, right-click the task and select Delete from the pop-up
menu.

✍ Exercise: Manage Tasks
You already started with your tasks from the last exercise
(page 284). Enter the following percentage of completenes:

❶ Mow you lawn → 25%

❷ Prepare a presentation for your Latin course → 80%

❸ Buy a birthday present for your friend → 0%

❹ Phone your grandmother → 100%

❺ Clean your room → 0%
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3.8.20 Assign Tasks

You can use the Evolution Tasks module to assign a task to a classmate
or to members of your team. Assigning a task is very similar to setting
up a meeting.

Open the menu and select Assigned Task. Alternatively, you can
select File → New → Assigned Task.

The standard Task dialog opens. However, now it has an Attendees area.

✍ Exercise: Assign Tasks
Use what you have learned in the section about setting up a
meeting (see page 278) and assign a task to a classmate. Your
classmate should accept the task.

3.8.21 Use Memos

Evolution contains a Tasks module for managing memos.

To start this module, select the Memos button in the left
frame of the Evolution dialog.
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The Memo dialog appears:

The available memo lists are listed in the small frame above the module
buttons on the left side of the window. The large frame on the right shows
the individual tasks.

You might want to store private memos and school memos in separate
memo lists. Create a new memo list by doing one of the following

Z Selecting File → New → Memo List

Z Selecting Memo List from the pull-down menu

Under Type, indicate where you want the
memo list to be located. Under Name you can
enter a name for your new memo list. Under
Color, you can select a background color for
the memos shown in the memo view.

To remove a memo list, you have to right-click the memo list and select
Delete from the pop-up menu.
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✍ Exercise: Create a New Memo List
Create a new memo list “Classmates” on your computer.

3.8.22 Create a New Memo

To create a new memo, select in the tool bar.

The Journal dialog appears:

290 c©2007 Novell Inc. Copying or distributing all or part of this manual
is protected by a Creative Commons

Attribution-NonCommercial-ShareAlike 2.5 license.



3.8 Use the Collaboration Software Evolution

The dialog includes the following items:

Z Group. Name of the memo list the memo should be stored in.

Z Description. Type the content of the memo.

When creating a memo, you can select View → Categories to select
categories for the memo.

3.8.23 Customize Evolution

You can customize Evolution by selecting Edit → Preferences. A new
dialog appears.

The configuration modules
are listed here.

Most of the modules contain several tabs. Here you can change the data
you entered into the wizard when started Evolution the first time.
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3.9 Use Gimp to Manipulate Images

You can use Gimp, a free graphics application, to process scanned photos
or images from the Internet. “Gimp” is an acronym for “GNU Image
Manipulation Program.” The application is very powerful, but it requires
some practice to use effectively.

i The web pages for the Gimp project can be found at
http://www.gimp.org.

At http://www.gimp.org/docs you can find the official Gimp user
manual.

3.9.1 Start Gimp

To start Gimp, you can select the icon labeled The GIMP

in the Images group of the Application Browser.

When you start Gimp the first time, some files are created in your home
directory. For this, a wizard starts.

Select to go to the next dialog.
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Gimp creates a new directory .gimp-2.2 inside your home directory. This
includes several files and subdirectories. You can select a file in the left
frame of the dialog and the wizard shows some more information about
it.

Files and directories with a name that begins
with a dot (“.”) are hidden. To see them
in Nautilus you have to select View → Show

Hidden Files.

Select to go
ahead.

The next dialog shows a
log of the file creation.
Everything should be
fine.

Select again.
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In this dialog you can adjust the memory usage of Gimp to store image
data. Also, you can enter a swap directory where the data that does not
fit into the memory is stored.

Normally, it is not necessary to change anything and you can proceed by
selecting and Gimp starts the first time.

✍ Exercise: Start Gimp
Start Gimp and proceed through the wizard.
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3.9.2 Know the Gimp Windows

Three windows appear on the screen:

❶ GIMP Tip of the Day

❷ The GIMP

❸ Layers, Channels, Paths, Undo. . .
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❶ GIMP Tip of the Day

Gimp shows a tip. The Tip of the Day is very useful to become more
comfortable with the program over time.

Deactivate this if you do not
want another tip the next
time the program starts.

Select to close the dialog.
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❷ The GIMP

The GIMP window is the main window of Gimp. Here you can select
the tools and specify more detailed tool options in the lower part of the
window.
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You can categorize the tools into four groups:

Selection tools Layer tools Draw tools other tools

✍ Exercise: Know the Gimp Windows
In the table above, insert the name of each tool.
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❸ Layers, Channels, Paths, Undo. . .

The upper frame of the window has four
tabs:

– An image has at least one layer, la-
beled Background by default. A
layer is comparable with a transpar-
ent foil. The upper layers hide or
overlay the lower ones.

– Each color on the computer screen
is a mixture of the three colors red,
green, and blue. A channel shows
how much of each basic color is used.
Regions with lots of basic color are
shown in white. Regions with little
basic color are shown in black.

If you mix 100% red with
100% green with 100% blue
you get the color white.

– A path is a bezier curve like you
may be familiar with from vector
oriented draw programs. You can
create a selection from a path and
vice versa.

– List of the last actions. To undo select the last valid step.

To undo one step you can press Ctrl + Z .
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The lower frame of the window has four tabs:

– Select a brush from this menu.

– Select a fill pattern from this menu. To fill a selection with a

pattern, use and select fill type Pattern Fill in the lower
frame of the GIMP window.

– Select a gradient from this menu. To fill a selection with a gradi-

ent, select in the lower frame of the GIMP window.

3.9.3 Open and Save Image Files

To open a file in Gimp, you must first choose Open from the File menu
of the GIMP window. This opens the standard Gnome dialog from which
you can select the file you want to open. The loaded image is displayed
in a new window.

Most functions of Gimp can be
accessed by the menu bar on
the top of every image window.
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This menu is available by right-clicking the image.

The same menu as is in
the top of the window.

To save the image, you select File → Save as from the image menu.

The default file format of Gimp is XCF. All selections and layers are
stored.

✍ Exercise: Open and Save Image Files
Open the file examples/Gimp/couple.jpg from the course
CD. Save the opened photo as XCF file into your home direc-
tory.

3.9.4 Select Regions

The most important thing you have to know for photo manipulation is
how to create a selection. Before you can copy a person from one photo
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into another or before you can change the color of a person’s clothes you
have to select the region you want to use.

You may already know how to use the selection tools:

– Rectangular selection

– Elliptical selection

– Hand-drawn selection

– Contiguous selection

– Color selection

– Select a shape at it contours

– Curves selection

Rectangular, elliptical, and hand-drawn selection are very easy. They
work as expected.

✍ Exercise: Select Regions – Part 1
Create an elliptical selection. What are the changes in be-
haviour when you keep the following keys pressed while mov-
ing the mouse?

Z Shift

Z Ctrl

Z Alt

Normally a new selection replaces the old one. If you press Shift
before clicking the mouse button to start the second selection (a small
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plus appears next to the mouse pointer), both selections are combined.
If you press Ctrl before clicking the mouse button to start the second
selection (a small minus appears next to the mouse pointer), the second
selection is removed from the first one.

Alternatively you can use the icons in the lower frame of the
GIMP window:

– The new selection replaces the old one

– The old selection is enlarged by the new one

– The old selection is reduced by the new one

– Only the region that is part of both selections is selected

With the contiguous selection tool, you can select a point in the image,
and a region around that point with similar colors is selected.

✍ Exercise: Select Regions – Part 2
What happens if you select the contiguous selection tool, keep
the mouse button pressed and move the mouse to the right
and to the left?

The color selection tool selects all points in the image that have
the same color as the selected point.

Using the shape selection tool select some points around a shape. The
tools try to detect the contours of the shape. The last and the first point
must be identical. If you click in the center of the shape, the shape is
selected.

✍ Exercise: Select Regions – Part 3
Select all windows.
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The curve selection tool is not really a selection tool. You can
also use it for drawing.

It works similar to the bezier tool you might know from vector oriented
graphic programs. Select a point, keep the mouse button pressed and
move the mouse. If the curve is fine, release the mouse button and select
the next point.

When you want to finish the curve, there are two buttons in the lower
frame of the GIMP dialog you can select:

❶ Creates a selection from the path you draw.

❷ Draws a path. For this a dialog appears where
you can specify the options of the path.

✍ Exercise: Select Regions – Part 4
Select the brush drawing tool ( ) and try to scribble inside
and outside the selection. What happens?

As you see, a selection can be used to protect regions of unintended ma-
nipulation or to limit a manipulation only to a part of the picture.

Concerning selections, there is a menu item Select in the image menu.
We can not describe all of the menu items here, but the most important
items are:

All – Selects the whole picture.
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3.9 Use Gimp to Manipulate Images

None – Removes all selections.

Invert – Inverts the selection.

Shrink – Shrinks the selection. You can enter how much the selection is
shrinked into the appearing dialog.

Grow – Enlarges the selection. You can enter how much the selection
is enlarged into the dialog, which is very similar to the shrink
dialog.

Border – A border is drawn around your selection and maked as the new
selection. You can enter the thickness of the border into the
dialog.

3.9.5 Use Layers

You can copy the region you selected into the clipboard by selecting Edit

→ Copy. Or select Edit → Cut to cut your selection.

To paste there are three menu items available:

Paste – Normal paste

Paste Into – Pastes the content of the clipboard into the current se-
lection.
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Paste as New – Creates a new image from the content of the clipboard.

The pasted layer appears in
the Layer dialog and is selcted.

Select the Move Layer tools ( ) from the toolbox to move the pasted
layer.
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Now you have the following possibilities:

❶ You can select the white paper icon below the layer frame ( ).
The pasted layer is made into a new “real” layer.

❷ You can select the anchor icon below the layer frame ( ). The
pasted layer is added to the background.

❸ You can select the trash icon below the layer frame ( ). The
pasted layer is deleted.

If you have more than one layer you can select the mode which controls
how the layer on the top influences the layers below. For this, use the
Mode menu.

Modes other than Normal

produce interesting effects.

Select the opacity of the
activated layer here.

When selecting the eye icon ( ) in front of each layer entry, the layer
is made invisible.

If you select the label of the layer, you can rename it.

✍ Exercise: Use Layers
Create a new layer labeled “Test Layer” and select it. Now
you can start testing the draw tool in the next section without
destroying the original image.
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3.9.6 Use Draw Tools

We can not cover all of the drawing tools here in detail, but we want to
introduce the most important features.

Use the pencil , the brush and the airbrush tool to draw free-
hand.

✍ Exercise: Use Draw Tools
Describe the difference between the pencil, the brush and the
airbrush tool.

Before you start drawing you can select a brush from the lower part of
the Layers dialog.

Make sure that the brush
tab is selected.
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3.9 Use Gimp to Manipulate Images

Alternatively you can select
the Brush icon in the lower
part of the GIMP dialog.

First, select the color in which you want to draw. In the
GIMP dialog there is a area where you can select the
color of the foreground (the left box) and the color of
the background (the right box).

If you select one of the boxes, the color selection dialog appears.

You can select the color from the vertical rainbow bar in the center of the
dialog. The selected color of the rainbow is shown in the top right corner
of the left square.

Now you can select the saturation (vertical axis of the left square) and
the brightness of the color (horizontal axis of the left square).
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In the bottom right color there are twelve small empty squares, which can
be used to store colors. For this, select .

When you finish, select .

To change foreground color and background color, select .

To switch back to black and white, select .

The erase tool ( ) works similarly to the brush tool, with the exception
that all colors are removed from the selected layer and the content of the
lower layers appears.

To “draw” text, select the text tool ( ). In
the lower part of the GIMP dialog, you can
specify text options such as

Z Font

Z Font size

Z Color

Z Alignment

If you click inside the image, a simple dialog
appears and you can enter the text.

For each bit of text you enter, a new layer is added. The name of the
layer is the same as the entered text.
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3.9 Use Gimp to Manipulate Images

A text layer.

To use the filling tools and it is helpful to make a selection first.
For pattern fill you can select a pattern from the lower part of the layers
dialog.

Make sure the pattern
tab is selected.

For gradients, the frame looks like this:

Select the gradient tab.
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In the tool options of the pattern fill (lower frame of the GIMP dialog)
you can select whether you want to fill your whole selection, or select
similar colors.

Select this option to fill
the whole selection.

To fill a selection with a gradient, click inside the selection, keep the left
mouse button pressed and move the mouse in the direction of the gradient.
When you release the mouse button, the selection is filled.

You can select different
types of gradients here.
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There are several different types of gradients available:

Z Linear

Z Radial

Z Square

Z Conical

Z Shaped

Z Spiral

The clone tool ( )is useful for copying a texture in the photo to a new
location. This is needed when you have created things you want to du-
plicate.

First, position the cursor into the area you want to copy. Then press
Ctrl and click into the image. Thereafter you can release Ctrl and
start painting.

3.9.7 Know Other Important Tools

There are two more tools you will use very often:

Z Color selection tool ( )

Z Zoom tool ( )

Use the color selection tool to pick a color from the image. A dialog
appears and the picked color is shown.
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By default the foreground color is replaced by the picked color. You can
change this in the lower frame of the GIMP window.

Select what to do
with the picked color.

You can pick a color directly by pressing
Ctrl . This works not for all but for a lot of
tools (e. g. pencil, brush).

The zoom tool by default zooms in the image. If you keep Ctrl pressed,
the tool zooms out.

More zoom options are
available at View→ Zoom in
the image menu.
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3.9 Use Gimp to Manipulate Images

Press 1 to switch to 100% view.

✍ Exercise: Use Gimp Tools
Open the file examples/Gimp/house.jpg from the course CD.

Remove all the cars and refill the “holes” with the wall behind.

3.9.8 Improve Colors

Sometimes the colors of an image are not ideal. A picture might be
discolored by flash overexposure or might have received an odd tint during
the scanning process. In other cases, bad lighting might have led to
underexposure. Gimp offers various options for postprocessing and color
correction. You can access the color correction options by selecting Layer

→ Colors in the image menu.
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Make sure that the correct layer is selected.

Lets take a brief look at some of the dialogs:

Z Color Balance. Change the colors for shadows, midtones and high-
lights. You can add:

➪ Cyan or red

➪ Magenta or green

➪ Yellow or blue

Remember that it is possible to mix colors.
Red and blue generates magenta. Blue and
green generates cyan. Green and red generates
yellow.

Red and cyan are complementary colors. Also,
magenta and green, and yellow and blue.
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3.9 Use Gimp to Manipulate Images

Z Hue-Saturation. You can change hue, lightness, and saturation for
the whole image or the six basic colors:

➪ Red

➪ Magenta

➪ Blue

➪ Cyan

➪ Green

➪ Yellow

Z Colorize. The image is converted to grayscale. In the colorize
dialog you can change hue, saturation, and lightness of the main
color.
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Z Brightness-Contrast. You can use Brightness-Contrast to
darken bright images (Brightness) and brighten dark images. You
can make colors appear stronger by raising the value with Contrast.

This figure illustrates the difference between the ori-
ginal color in the upper left half of the image and a
slightly increased contrast in the lower right half.

Z Curves. In this dialog you see can change the brightness of the
image. At the left you see the dark colors, at the right the light
colors.
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3.9 Use Gimp to Manipulate Images

This curve shows how many points
in the image have this brightness

If you click the black diagonal line, you can add points and twist
the line. If you twist the line higher than the diagonal, the effected
colors are lightened. If you move it down to the diagonal, they are
darkened.

Z Posterize. Use this dialog to reduce the number of colors.

Z Desaturate. Converts the image directly to grayscale.

Z Invert. Inverts the image.

The Layer → Colors → Auto option offers you five proven color en-
hancement procedures to try. These procedures produce variable results
depending on the source image, but trying these automatic procedures
may be worthwhile. If the changes are not acceptable, you can undo
them by right-clicking the image and then selecting Edit → Undo or,
alternatively, using the keyboard shortcut Ctrl + Z .
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✍ Exercise: Improve Colors
Improve the colors of the house photo.

The color of the sky is nearly white on the house photo.
Change it to blue.

3.9.9 Use Effects

Gimp provides several special-effects tools. Filters in the image menu
offers a number of submenus that contain various special-effect functions.

Not all effects can be applied to all image modes. Some effects require
a selection; some do not. Some only make sense when applied to a color
image, some only when applied to monochrome images. Many filters
require a lot of processing power, so you may have to wait for the results
to be displayed on slower computers.
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✍ Exercise: Use Effects
Create five variations of the
house.jpg photo using five
different effect filters.

3.9.10 Use Script-Fu

Gimp can be extended by “Script-Fu” modules. These modules are stored
in the directory /opt/gnome/share/gimp/2.0/scripts/ and written in
a Gimp specific language, called “Script-Fu.”

These scripts often simply combine dif-
ferent Gimp tools and effects. So you can
automate complex tasks, such as creating
a slide with your image or to create a logo
for your website.

You can find the predefined Script-Fus un-
der Script-Fu in the image menu or at
Xtns → Script-Fu

✍ Exercise: Use Script-Fu
Test five Script-Fu scripts.

3.9.11 Create a Screenshot

You can create a screenshot directly in Gimp via File → Acquire →
Screen Shot from the GIMP menu.
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You can select whether you want to capture the whole screen or a single
window. Also, you can specify whether the screen should be captured
immediately or after a delay.

✍ Exercise: Create a Screenshot
Create a screenshot from you GNOME environment showing
an opened main menu.
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3.10 Enable Multimedia

3.10.1 Use a Sound Mixer

To control the volume, select the small loudspeaker icon
in the bottom right corner. Clicking with the left mouse
button it opens a slider to control the volume.

If you want to manage the volume of the different sound devices in de-
tail, select the loudspeaker icon with the right mouse button and select
Open Volume Control from the popup menu. You also can select Volume
Control from the Audio & Video group in the Application Browser.

The dialog that appears may look
different on your computer, depend-
ing on the available sound hardware.

The Playback tab shows volume sliders for the available output devices.

Mute a device here.
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The two sliders in the previous image are:

– The master volume control

– The volume of the PCM device (Pulse Code Modulation)

The Capture tab normally shows more icons.

There are only the most important input devices
shown. If you want to add other devices, select Edit →
Preferences.

To mute a device select the loundspeaker icon of the corresponding slider.
If you want to record from a device, activate the corresponding micro-
phone icon at the bottom of the slider.
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3.10.2 Play Music

To play music files (such as Ogg Vorbis or MP3) or Audio
CDs, run the Banshee program from Helix. You can do this
by selecting the Helix Banshee icon in the main menu.

A dialog with the Banshee license appears, when you start Banshee the
first time.

After accepting the license, the Banshee dialog appears.
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It also appears a small dialog in the foreground, that asks whether you
want to import existing music files from your hard disk.

Select your music directory
here and select .

If you do not want to import music, select . To import later, you
can select Music → Import Music. The imported songs should be listed
in the right frame.

Also if you put an audio CD into your CD-ROM, the songs should be
listed in the right frame.

If you select the button the selected songs of the CD are ripped
and imported.
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Select the songs you
want to import.

The songs are stored as MP3 files in the directory ∼/Music by default.

You can arrange songs in a playlist. Select Music → New Playlist.

A playlist icon ap-
pears in the left frame.

To rename the playlist, rightclick the icon and select Rename Playlist.
To remove a playlist, select Delete Playlist from the popup menu.

Use drag and drop to fill the playlist with songs from the music library.
You also can use drag and drop to change the order of the songs in the
playlist.

To start playing the music, select .
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3.10.3 Watch Movies

Although it is technically possible to watch movies with Linux, a lot of
legal issues must be considered. The movie on a DVD is encrypted and
cracking encrypted information is illegal. Applications are available on the
Internet to watch DVDs. However, these programs are illegal; therefore
Novell is not allowed to include them in the distribution or on the course
CD.

Another problem is proprietary file formats. Quicktime is a format that
was developed by the Apple Computer, Inc. Because Apple has not
made Quicktime available for Linux, you must use either illegal tools
from the Internet or use an emulation utility like CrossOver Office from
Codeweavers Inc. to view a Quicktime movie.

You can watch Real movies without any problems using the Linux version
of the RealPlayer.

To start RealPlayer, select Multimedia → RealPlayer.

Before you can start RealPlayer the first time, you have to set it up. A
welcome dialog appears.
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Select and the release notes are shown.

Select to see the license for RealPlayer.
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Here select .

In this dialog you can select whether RealPlayer should look for new
updates and whether tools should be installed that simplifies to see Real
videos included in web pages.

Select to start RealPlayer.

Change the volume here.

You can open a file on your harddisk by selecting File → Open File....
With Open Location... you can open a file somewhere on the Internet
by entering the URL.
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It is also possible to hear sound files like WAV with RealPlayer. If you
open an audio file, the RealPlayer dialog changes a little bit.

Another program, you can use to play unencrypted
DVDs, see videos or audio files is Totem. You can start
it by selecting the Totem icon in the Audio & Video

group of the Application Browser.

Totem supports playlists.

Use to activate and deactivate the sidebar with the playlist.

In the View menu you can switch between normal window size and
fullscreen by selecting Fullscreen. You can leave the fullscreen mode
by moving the mouse. In the top right corner a button appears.

Much more easier to switch between normal
window size and fullscreen is to press F .

c©2007 Novell Inc. Copying or distributing all or part of this manual
is protected by a Creative Commons

Attribution-NonCommercial-ShareAlike 2.5 license.

331



3 Use Open Source Tools

332 c©2007 Novell Inc. Copying or distributing all or part of this manual
is protected by a Creative Commons

Attribution-NonCommercial-ShareAlike 2.5 license.



Appendix

c©2007 Novell Inc. Copying or distributing all or part of this manual
is protected by a Creative Commons

Attribution-NonCommercial-ShareAlike 2.5 license.

333



Appendix

334 c©2007 Novell Inc. Copying or distributing all or part of this manual
is protected by a Creative Commons

Attribution-NonCommercial-ShareAlike 2.5 license.



Index

Index

*, 56, 105
.gimp-2.2, 293
/etc/passwd, 19
?, 56, 105

Access, 153
address book, see Evolution
administrator, 14
AIM, 233
application browser, 34
appointment, see Evolution
Ar, 60, 110
Ark, 109–111
Assembler, 4
audio CD, 325–327
authentication, 249
auto login, 21

background, 66
Banshee, 65, 325–327
Beagle, 55–56, 74, 86, 107–109
bell, 75, 130
bitmap, 221
boot loader, see GRUB
BSD UNIX, 4

C, 4
CalDAV, 272
CD

audio, 325–327
CD-ROM, 45

chat, 232–242
Clipboard, 86
clock, 31, 86
collaboration software, 243–291
complementary colors, 316
Control Center, 61–77, 88, 111–

135
Control Panel, 84, 85
cookies, 143–146
country, 128
CrossOver Office, 328

desktop
icons, 35
virtual, see virtual desktops

directories
most important, 45–46
permissions, 53

directory
create, 46, 98

DISPLAY, 28
display, 31, 124
domain, 19
dot, 221
drawing, 221–232
DVD, 328

Ear, 60
email, 86, 250–262
Evolution, 243–291
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address book, 262–267
appointment, 273–282
attachment, 251, 254–255
Bcc, 252
calendar, 268–282
carbon copy, 252
category, 264, 266, 276, 277,

285, 286
Cc, 252
configure, 243–250
contact, 262–267
contact list, 266–267
email, 247–262
filter, 256–262, 276–278, 285
folder, 255–256
forward, 253
HTML, 252
inbox, 256
meeting, 278–282
memo, 288–291
memo list, 289–290
recurrences, 274–276
reminder, 273
reply, 253
settings, 291
task, 282–288
task list, 282–283
thumbnail, 254
time zone, 250
wizard, 243–250

Excel, 153, 188
Exchange, 246

file
execute, 53
group, 53
hidden, 293
others, 53

owner, 53
read, 53
write, 53

file manager, 39–55, 85, 94–105
file names, 42
File Roller, 58–61
file system, 42–46, 98

principles, 43
structure, 43

files
archive, 58–61, 109–111
connect, 51, 103
copy, 47–48, 99–100
delete, 49–51, 101–102
link, 51, 103
move, 47–48, 99–100
permissions, 52–55, 104–105
rename, 48, 100
search for, 55–58, 105–109

Firefox, 136–151
address bar, 136, 149
bookmark, 138–141
cache, 146
cookies, 143–146
downloads, 146
extentions, 151
history, 137, 146
passwords, 146
print dialog, 141, 142
search, 137
SSL connections, 148–149
stored data, 146–148
tabbed browsing, 137
themes, 150

floppy disk, 45
focus, 70
font, 67
fonts, 132
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Gaim, 232–242
account, 233–235
alias, 234, 236
auto login, 234
away, 241
block, 239
buddy, 236–238
buddy list, 237
font, 239
group, 238
image, 239
line break, 239
link, 239
message, 240
panel, 242
password, 234
preferences, 241
privacy, 239
protocol, 233
screenname, 234, 236
send, 239
smiley, 239
status, 240

Gimp, 292–322
airbrush, 308
background, 309
bezier, 304
brightness, 318–319
brush, 300, 308, 309
channel, 299
clone, 313
color, 309
color balance, 316
color correction, 315–320
color selection, 313–314
colorize, 317
colors, 315–320
contrast, 318

curve, 304
effects, 320–321
erase, 310
fill, 300, 311
foreground, 309
freehand, 308
gradient, 300, 311
grayscale, 319
hue, 317
image menu, 301
invert, 319
layer, 299, 305–307, 310
path, 299, 304
pattern, 300, 311
pencil, 308
posterize, 319
region, 301–305
saturation, 317
screenshot, 321
Script-Fu, 321
selection, 301–305
shape, 303
swap, 294
text, 310
tip, 296
tools, 297–298, 302–305, 308–

315
windows, 295–300
wizard, 292–294
zoom, 313–315

GNOME, 27, 30–55
application browser, 34
Control Center, 61–77
customize, 61–77
fonts, 67
icons, 35–39
keyboard, 62
log in, 30
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main menu, 33–34
menu, 68
mouse, 63
network, 72
NetworkManager, 31
panel, 31
power management, 72
proxy, 72
screensaver, 68
search, 74
Sessions, 74
shortcuts, 71
sound, 75
task manager, 31
theme, 69
toolbar, 68

GNU General Public License, see

GPL
GPL, 5
graphic card, 22
GroupWise, 246
Groupwise, 233, 243
GRUB, 11

hardware, 21, 61
Helix Banshee, see Banshee
help, 154–156
Help Center, 86
hidden files, 293
home directory, 45
host, 249
HTML, 252
Hula, 246

icons, 35–39, 90–94
ICQ, 233
image, 221–232
IMAP, 246
index, 180

installation, 7–13
KDE, 77–81
software, 77–81

Instant Messaging, 232–242
internet connection, 15
IRC, 232

Jar, 60

KDE, 27, 77–135
accessibility, 128
background, 112
Colors, 113
Components, 84–89
components, 122
Control Center, 88
crypto, 129
customize, 111–135
desktop, 84, 90
fonts, 114
icons, 115
install, 77–81
Internet, 122
login manager, 132
menu, 83–87, 91
network, 122
panels, 119
passwords, 130
paths, 132
peripherals, 124–127
privacy, 129
screen saver, 116
security, 129
splash screen, 116
style, 116
taskbar, 120
themes, 117
wallet, 130
window decoration, 117
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Kerry, 107–109
keyboard, 11, 25, 62, 125

layout, 128
shortcuts, 129

keyring, 235
Kicker, 84, 85, 91, 119
Konqueror, 85, 86, 94–105

customize, 94
icons, 94
navigate, 95
navigation panel, 95

Kontact, 86

language, 8, 128
LDAP, 19
Lha, 110
licence, 5
links, 51, 103
Linus Torvalds, see Torvalds
local delivery, 246
log in, 30, 81
log out, 35, 83
login manager, 132
login string, 30

mail client, 73
Maildir, 246
main menu, 33–34, 38
mbox, 246
meeting, see Evolution
menu, 68
menu editor, 91–93
Metacity, 27
MH mail directories, 246
mixer, 86, 323–324
mouse, 25, 63, 126

pointer, 126
movie, 328–331
Mozilla Foundation, 136

MP3, 325
MSN, 233
MULTICS, 3
multimedia, 323–331
multiple desktops, 119
music, 323–327
mute, 324

Nautilus, 39–55, 293
NetworkManager, 15, 31, 86
news, 246
NIS, 19
Novell Customer Center, 16

Ogg Vorbis, 325
online update, see updates
OpenExchange, 243
OpenOffice, 152–232

alignment, 164
alingment, 179
arrow, 224
attributes, 207
AutoPilot, 195–196
background, 210, 217, 218
Base, 153
brackets, 207, 208
Calc, 153, 185–205
cell address, 192
character, 163–164
charts, 196–199
color, 163, 165
column, 190
curve, 224
customize, 156
data types, 189, 191–192
database, 202–205
document, 158–161
Draw, 221–232
effects, 225
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ellipse, 224
file formats, 154
fill, 227–229
font, 163
font gallery, 225
font size, 163
formats, 207
formula, 192–196, 206–208
functions, 207
gallery, 226
greek symbols, 208
grid, 230
group, 208, 229
Help, 154–156
Help Agent, 155
image, 174–177
Impress, 153, 209–221
indent, 165–168
insert, 174–180
layout, 211
line, 224, 227–229
lists, 165
Master Page, 218
Math, 206–208
Maths, 153
operators, 194, 207
page, 169
paragraph, 164–169
PDF, 160
presentation, 220
preview, 184
print, 182–184, 200–202
printer, 183
rectangle, 224
relations, 207
row, 190
serial letter, 202–205
sheets, 186

slide, 211–220
Slide View, 216
snap line, 232
spell checker, 173–174
style, 164, 168–169
Stylist, 170–172
SUM, 193–194
support, 154–156
symbols, 208
table, 178–179
tabs, 166–168
template, 172, 210
text flow, 176
tools, 224
transition, 210, 219
web forum, 156
wrap, 176
Writer, 153, 157–184
zoom, 172–173

panel, 38
partition, 11
password, 20, 30, 70, 130, 235

root, 14
patch, 18
PDF, 160
point, 221
POP, 246
power management, 86
power control, 125
power management, 72
Powerpoint, 153, 209
presentation, 209–221
printer, 22, 64, 126
proxy, 72
punch cards, 3

Quicktime, 328
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Rar, 110
RealPlayer, 328–331

update, 330
record, 324
region, 128
release notes, 21
remote control, 127
resolution, 221
root, 14
runlevel, 11

screensaver, 68
screenshot, 321
search, 74, 86
Sendmail, 248
shortcuts, 71
side panel, 41
SMTP, 248
snap line, 232
software, 11

install, 77–81
update, 86

sound, 75, 130–132, 323–327
file, 325, 331
mixer, 86, see mixer
system, 72, 130
volume, see volume

sound card, 22
spreadsheets, 185–205
SSL connections, 148–149
StarOffice, 152
support, 154–156
SUSE Help Center, 86
system

administration, 132
bell, 130
notifications, 75, 131

system bell, 75

system mail, 20
System V, 4

Tab Window Manager, 27
table of contents, 180
tar, 60
task manager, 31
taskbar, 120
TCP/IP, 26
temporary files, 46
terminal, 73, 85
text editor, 73
theme, 69
time, 31, 86
time zone, 11, 250
titlebar, 70
toolbar, 68
Torvalds, 5
Totem, 331
trash, 49–51, 101–102
twm, 27, 29

UNIX, 4
updates, 17–18, 31, 86
USB stick, 45
user

create, 20–21
username, 30

vector drawing, 223
vector image, 221
video, 328–331
virtual desktops, 84, 86, 88–89,

119
volume, 31, 323–324

War, 60
WAV, 331
web browser, 73, 86, 136–151
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widget, 114
wildcards, 56, 105
window manager, 26–29
Windows, 19
Word, 153, 159

X client, 25–29
X server, 25–29
X Window System, 25–29
X11, see X Window System
XCF, 301
XFree86, see X Window System
Ximian, see Evolution
xterm, 28

YaST, 8, 76, 77
YOU, 17–18

Zip, 60, 110
Zoo, 110
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